Bienvenida

Password Safe

¿Cuántas contraseñas y nombres de usuario tienes que recordar? Tanto si la respuesta es una o cientos, Password Safe te permite crear de una forma fácil y segura lista encriptada de contraseñas segura. Una única contraseña maestra desbloquea a todas para su uso.

La seguridad empieza con el usuario. Mantener listas de contraseñas escritas en pedazos de papel, o en un documento de texto en el escritorio es inseguro y está a la vista de los ojos curiosos (humanos y de software). Utilizar la misma contraseña una y otra vez en un amplio espectro de sistemas y sitios web crea un escenario de pesadilla en la que una vez que alguien ha descubierto una contraseña, se han descubierto todas sus contraseñas y ahora tienen acceso a cada parte de tu vida (sistema, correo electrónico, comercio minorista, finanzas, trabajo).

Password Safe te permite administrar tus viejas contraseñas y generar, almacenar, organizar, recupuerar y usar nuevas y complejas contraseñas de una manera fácil y rápida, utilizando políticas de contraseñas que controlas. Una vez almacenadas, tus usuarios y contraseñas están a unos clic de distancia.

Usando Password Safe puedes organizar tus contraseñas utilizando referencias personalizables —por ejemplo, por identificador de usuario, categoría, sitio web or ubicación. Puedes optar por almacenar todas tus contraseñas en una única lista encriptada de contraseña maestra (una base de datos de contraseñas encriptada), o utilizar múltiples bases de datos para organizar tus contraseñas (trabajo y casa, por ejemplo). Todo esto con una interfaz intuitiva que estará lista y funcionando en minutos.


Acerca de Password Safe

Password Safe y el algorítmo de encriptación Twofish que usa fueron desarrollados y liberados al público por Bruce Schneier y Counterpane Labs.

Password Safe es un proyecto de código abierto alojado en sourceforge.net. Las últimas actualizaciones del programa, documentación, y noticias se encuentran en http://pwsafe.org.

Password Safe está disponible libremente y puede distribuirse bajo las restricciones establecidas en el estandar Open Source Initiative (OSI) "Artistic License 2.0." Se incluye una copia de esta licencia con el paquete de instalación de Password Safe en el archivo llamado LICENSE.

Twofish es una alternativa rápida y libre de los algoritmos de encriptación AES, DES e IDEA. Los detalles del algoritmo Twofish, incluyendo comparativas de velocidad y una completa lista de productos que usan Twofish, están disponibles en http://www.schneier.com/twofish.html.

Por favor lee los archivos readme.txt, changelog.txt, y releasenotes.txt en el paquete de instalación para encontrar los últimos cambios, parches y añadidos a la documentación.

Las demás marcas o nombres de productos son marcas registradas de sus respectivas compañías. No existe soporte o apoyo tacito de estas compañías.


Creación de una base de datos

Crear y abrir una base de datos

Password Safe permite a los usuarios almacenar todas sus contraseñas en una única "caja de seguridad" (base de datos de contraseñas), o crear multiples bases de datos para diferentes propósitos (por ejemplo, una para el trabajo, otra para uso personal). Cada base de datos es independiente se puede mover y utilizar en diferentes sistemas, siempre que esté instalada la misma versión de Password Safe. Las bases de datos se encriptan con una clave derivada de la contraseña maestra(la contraseña maestra no se guarda en la base de datos de ninguna forma).

Si es la primera vez que usas Password Safe, pulsa el botón Nueva base de datos. Se te pedirá elegir el nombre y la ubicación de tu base de datos de contraseñas (el valor predeterminado, "pwsafe.psafe3", está bien). Posteriormente, se te pedirá que introduzcas una contraseña maestra que se utilizará para cifrar y bloquear el contenido de su nueva caja fuerte.

Crear una nueva base de datos

Hay dos formas de crear una nueva base de datos. Pulsando Nueva base de datos desde el diálogo Introducir contraseña maestra cuando se inicia el programa, o desde el menú Archivo > Nueva... cuando Password Safe ya está abierto. Utilizando cualquiera de los métodos hace aparecer el diálogo Configuración de contraseña maestra.

Nota: Por defecto, Password Safe mostrará la última base de datos que se utilizó, y pedirá la contraseña para abrirla. Si usas varias bases de datos, puedes elegir entre ellas usando la lista desplegable. Alternativamente, puedes escribir la ruta de acceso a la base de datos, o seleccionarla del cuadro de diálogo Archivo pulsando el botón de puntos suspensivos ("..."). Una vez que una base de datos está abierta, puede cambiar a otra a través de la opción Abrir... del menú Archivo.

Nueva contraseñas maestra

Teclado virtual

Para configurar una contraseña maestra segura, puedes usar caracteres (por ejemplo en un teclado alemán) como ä, ö o similar. Para introducir esos caracteres, necesitas un teclado de otro idioma. Ese teclado está disponible como teclado virtual. Se utiliza para simular todos los caracteres disponibles. El teclado virtual se muestra pulsando el símbolo Símbolo de teclado virtual . Los caracteres que no están disponibles en el teclado físico, pueden introducirse de esta forma. Así puedes fijer la contraseña maestra que desees. Incluso partes de la contraseña maestra pueden introducirse de esta manera.

Introducir una contraseña con un teclado virtual


Usar contraseñas almacenadas

Password Safe proporciona varios mecanismos para utilizar nombres y contraseñas almacenados. Se puede copiar el nombre de usuario o contraseña al portapapeles y luego pegar la información en el campo de entrada requerido. Password Safe proporciona una función, Autoescritura, que automatiza la introducción de usuario y contraseña en un formulario web.

  1. Abre Password Safe
  2. Selecciona la entrada con el usuario/contraseña que quieres usar
    Nombre de usuario:
  • Selecciona el icono de usuario de la barra de herramientas
    o
  • Clic derecho y selecciona Copiar usuario al portapapeles
    o
  • Usa Ctrl + U
    y depués Pega el nombre de usuario en el campo deseado.
    Contraseña:
  • Selecciona el icono de contraseña de la barra de herramientas
    o
  • Clic derecho y selecciona Copiar contraseña al portapapeles
    o
  • Doble clic en la entrada seleccionada
    o
  • Usa Ctrl + C
    y después Pega la contraseña en el campo deseado.
Nota: Usuario y contraseña también pueden copiarse al portapapeles con las opciones del menú Editar, aunque es mucho más trabajoso.


Buscar

Buscar un texto determinado

Password Safe te permite buscar entradas con un texto determinado. Esto es útil si no recuerdas el nombre de la entrada pero tienes una idea sobre su contenido, por ejemplo, la entrada con "María" en las notas.

Para buscar en una base de datos abierta pulsa Ctrl-F (o Editar->Buscar...). Aparece una barra de herramientoas sobre la barra de estado en la parte de abajo de la ventana de aplicación similar a la siguiente:

Barra de búsqueda

La forma más sencilla de usarlo es introducir el texto que está buscando, a continuación, pulsa Intro o haz clic en el icono de la lupa a la derecha del campo de texto. El número de entradas que coinciden (si lo hace alguna) se mostrará en la parte derecha de la barra de herramientas, y la primera entrada que coincida será seleccionada y remarcada Al pulsar Intro (o hacer clic sobre la lupa) se moverá a la siguiente coincidencia sucesivamente. Cuando todas las entradas han sido seleccionadas, Password Safe volverá de nuevo a la primera.

La tecla F3 repite la búsqueda. Sigue presionando F3 para cambiar a la siguiente entrada que satisfaga los requisitos. Manteniendo pulsada la tecla Mayús. al pulsar F3, encuentra la entrada previa en la base de datos que satisfaga los criterios en lugar de la siguiente. Del mismo modo puedes pulsar la tecla mayúsculas mientras pulsas el icono de la lupa para encontrar la anterior coincidencia.

  • Para cerrar la barra de búsqueda, pulsa en la 'x' a la derecha del texto.
  • Por defecto, la busqueda no distingue entre mayúsculas y minúsculas. Para cambiar entre busqueda con o sin distinción de mayúsculas, pulsa en el botón 'AA', que cambiará a 'Aa' cuando la búsqueda distinga mayúsculas y minúsculas.
  • Para realizar un búsqueda más avanzada, como restringir la búsqueda a un subconjunto de entradas, determinar en que campos buscar, etc, pulsa en el icono "...".
  • Para crear un informe sobre los resultados de tu búsqueda, pulsa el símbolo crear informe de búsqueda .
  • Para borrar el texto de búsqueda, haz clic en el botón de la goma de borrar.


Actualizar desde versiones anteriores de Password Safe

A fin de soportar nuevas funciones y mejorar la seguridad, el formato de base de datos que se utiliza para almacenar las entradas y preferencias se ha cambiado entre las versiones principales. Sin embargo, se ha puesto mucho esfuerzo en garantizar una actualización automática y transparente:
  • La versión 1.x de Password Safe sólo puede leer bases de datos generadas por las versiones 1.x.
  • La versión 2.x de Password Safe puede leer bases de datos creadas por las versiones 1.x y 2.x de Password Safe
  • La versión 3.x de Password Safe puede leer bases de datos creadas por todas las versiones previas.
En todos los casos, para leer una base de datos generados por una versión anterior de Password Safe, sólo ábrela como cualquier base de datos. Las entradas se mostrarán con normalidad, con posibles valores "desconocido" de los campos que no estaban soportados en versiones anteriores (por ejemplo, la fecha de creación de una entrada).
Al guardar una base de datos de una versión anterior, se le alertará del hecho de que la base de datos guardada será ilegible para la versión anterior de Password Safe.

Generación de versiones anteriores de la base de datos

Puedes crear versiones de la base de datos que puedan ser leídos por las versiones más antiguas de Password Safe exportandola explícitamente al formato deseado (Archivo > Exportar a y seleccionar formato v1.x... or formato v2.x...). Tenga en cuenta que las bases de datos exportadas no contienen información que fue añadida en las versiones más recientes. Por ejemplo, una base de datos de la versión 2 no dispondrá de información relativa a la fecha de modificación de entradas.


Una nota sobre contraseñas maestras

Una de las claves más importantes para el mantenimiento de tu seguridad es seleccionar una contraseña maestra fuerte para tu base de datos Password Safe. La base de datos ("Segura") contiene todos tus usuarios, contraseñas y cualquier información adicional que hayas añadido. Escoger el nombre del cónyuge, un cumpleaños, o alguna otra combinación fáciles de adivinar hace sus datos vulnerables. Es importante que elijas una contraseña maestra difícil de adivinar que puedas recordar con facilidad.

Password Safe comprueba si la contraseña maestra es débil. Por lo general, una contraseña maestra (como cualquier contraseña) debe estar compuesta de una mezcla de mayúsculas y minúsculas con al menos un numero o carácter especial (como los que se encuentran por encima de las teclas numéricas en el teclado). Si se introduce una contraseña maestra que el programa considera débil, se le solicitará confirmación. Tienes la opción de aceptar la contraseña introducida (débil) o introducir una nueva.

Para cambiar tu contraseña maestra, consulta Cambiar las contraseñas maestras.

Nota: Password Safe no tiene un mecanismo para recuperar contraseñas de seguridad perdidas u olvidadas.
Esta es una decisión de diseño deliberada, ya que cualquier mecanismo para recuperar las contraseñas perdidas plantea un agujero de seguridad que pueden ser explotado.


Nombres de usuario y contraseñas

Nombres de usuario, contraseñas y grupos: Básico

Nombres de usuario, contraseñas y grupos junto con los parámetros adicionales se gestionan en 4 pestañas:

  • Básico: todos los elementos necesarios para la gestión de contraseñas
  • Adicional: especificaciones adicionales, incluyendo el historial
  • Fechas y horas: caducidad y estadísticas
  • Política de contraseñas: diferencias específicas sobre los valores predeterminados

Pestana básico

En esta pestaña se combinan los elementos más importantes.

Editar/Ver entrada

Cada entrada tiene asociados los siguientes datos:

  • Grupo: Un nombre para agrupar (organizar) varias entradas relacionadas
  • Título: Un nombre descriptivo de una entrada de contraseña
  • Usuario: El nombre de usuario
  • Contraseña: La contraseña
  • Notas: Campo de notas generales en formato libre
  • Sólo los campos título y contraseña son requeridos; el resto son opcionales.
Además, se dispone de los siguientes campos en la presente ficha:
  • URL: La URL asociada con la entrada. Si el campo no está vacío, el botón "Ir" está activo. Si no se especifica el protocolo se asume "http://" (por ejemplo, "www.foo.net" es lo mismo que "http://www.foo.net"). El botón Ir a la derecha del campo URL está activo si el campo URL no está vacio. Pulsando con la tecla control pulsada (Ctrl+Clic) además realizará la función autoescritura en la página abierta en el navegador. Ver las siguientes notas para más información
  • correo: La dirección de correo asociada con esta está entrada. Si el campo no está vacío, el botón "Enviar" está activo. Pulsando en este botón se llamará al programa de correo predeterminado con el campo A: fijado a la dirección especificada. Ver las siguientes notas para más opciones.
    Las siguientes notas describen las forma de tratar URLs con más detalle:
  • Por defecto, Password Safe usará el navegador predeterminado de tu PC. Si lo deseas, puedes especificar un navegador alternativo indicando '[alt]' antes de la URL, por ejemplo, "[alt]http://www.foo.net". Esto es útil, por ejemplo, si tu navegador por defecto es Firefox y quieres acceder a un sitio triste y lamentable que funciona mejor con Internet Explorer. Para configurar un navegador alternativo, utiliza el diálogo Herramientas->Opciones->Misc.
  • Si se indica '{alt}' antes de la URL, se pasa 'tal cual' al navegador alternativo, esto es, sin añadir 'http://' si no se especifica el protocolo. Esto es útil si el navegador alternativo es una aplicación de acceso remoto, por ejemplo, un cliente SSH. [ssh] tendrá el mismo efecto.
  • Si se indica '[autotype]' antes de la URL, después de que se muestre/active la URL, Password Safe realizará la acción de autoescritura usando el campo autoescritura de la entrada o el valor por defecto si el campo no está especificado.
La dirección de correo debe seguir la reglas estandar (por RFC 2368):
  • La dirección puede ser una o más direcciones de correo válidas separadas por punto y coma, utilizando caracteres 'Internet-safe'. Usa %20 para el caracter espacio.
  • La dirección puede ir seguido de uno o más parejas de nombre-valor. El primer par debe ir precedidos por un "?" y cualquier par adicional debe ir precedido por el signo y (&). El nombre puede ser una de las siguientes cadenas de texto:
    • subject - seguido por el texto que aparezca en la línea de asunto del mensaje.
    • body - seguido por el texto que aparece en el cuerpo del mensaje.
    • CC - seguido de las direcciones que se incluyen en el campo "cc" (con copia) del mensaje.
    • BCC - seguido de las direcciones que se incluyen en el campo "cco" (con copia oculta) del mensaje.
Ejemplo: usuario@ejemplo.com?subject=Título del mensaje&body=Contenido del mensaje"

Creando una nueva entrada de usuario y contraseña

  1. Abra la base de datos donde desea colocar la nueva entrada
  2. Desde el menú Editar, selecciona Añadir entrada
  3. Introduce la información necesaria en los campos del diálogo Editar/Ver entrada
Nota: Si un nombre de grupo es seleccionado y luego añade una nueva entrada, a entrada tendrá ese nombre Grupo precargada en el diálogo Editar/Ver entrada. Si se agrega un nuevo nombre de grupo al campo grupo, el grupo se creará.

Generando y editando contraseñas

Si lo desea, puede introducir su propia contraseña en el campo contraseña manualmente, o puedes hacer que Password Safe genere una nueva basada en la política de contraseñas actual. Para hacer que Password Safe genere una contraseña, pulsa en Generar en el diálogo Editar/Ver entrada. Si no te gusta el resultado, puedes volver a pulsar Generar de nuevo, o editar la contraseña manualmente.

Notas:
  • Si estás usando un sistema que te permite compartir la misma contraseña en distintas maquinas/servidores/aplicaciones, etc. puedes configurar las entradas de Password Safe en consecuencia, de manera que cambiar una contraseña afecte a todas las otras entradas relacionadas. Esto se conoce como "alias" de entradas y se explica en detalle aquí.

Editando entradas existentes

  1. Selecciona la entrada a editar en la lista
  2. Selecciona Editar/ver entrada desde el menú Editar
Nota: Por defecto, las contraseñas se ocultan. Para ver la contraseña asociada a la entrada pulsa en Mostrar.

Añadir un nuevo grupo

  1. Selecciona Añadir grupo desde el menú Editar
  2. Introduce el nombre del grupo

Editar el nombre de un grupo

  • Haz clic derecho en el grupo y selecciona Renombrar grupo de la lista desplegable
Nota: Los nombres de grupos pueden "anidarse", colocando un nombre de grupo dentro de/bajo otro nombre de grupo.


Nombres de usuario y contraseñas

Nombres de usuario, contraseñas y grupos: Adicional

Nombres de usuario, contraseñas y grupos junto con los parámetros adicionales se gestionan en 4 pestañas:

  • Básico: todos los elementos necesarios para la gestión de contraseñas
  • Adicional: especificaciones adicionales, incluyendo el historial
  • Fechas y horas: caducidad y estadísticas
  • Política de contraseñas: diferencias específicas sobre los valores predeterminados

Pestaña adicional

  • Autoescritura: Si este campo no está vacío, su contenido reemplaza el valor por defecto para la función de autoescritura. Para más información, ver el tema de ayuda "Autoescritura".
  • Ejecutar Cmd: Este campo puede usarse par indicar un comando o programa a ejecutar en la acción 'Ejecutar comando' (en el menú editar, menú contextual o Ctrl-R). Password Safe puede pasar argumentos al comando, tales como el usuario, contraseña, etc, tal como se describe aquí.
  • Acción al hacer doble clic: Esto te permite definir que acción realizará PasswordSafe al hacer doble clic sobre una entrada. Por defecto, se copia la contraseña de la entrada al teclado. La acción por defecto se fija en Herramientas->Opciones->Misc..
  • Historias de contraseñas: Se puede configurar Password Safe para guardar las últimas contraseñas de una entrada. Este puede hacerse al crear una entrada o al editar una entrada existente. Puees ver las contraseñas recientes relacionadas con la entrada. Puedes cambiar el número de contraseñas recientes a guardar. Para más información ver la página de historial de contraseñas.


Nombres de usuario y contraseñas

Nombres de usuario, contraseñas y grupos: Fechas y horas

Nombres de usuario, contraseñas y grupos junto con los parámetros adicionales se gestionan en 4 pestañas:

  • Básico: todos los elementos necesarios para la gestión de contraseñas
  • Adicional: especificaciones adicionales, incluyendo el historial
  • Fechas y horas: caducidad y estadísticas
  • Política de contraseñas: diferencias específicas sobre los valores predeterminados

Pestaña fechas y horas

Edit/View Dates and Times
  • Contraseña caduca el: Para establecer una fecha de caducidad de contraseña, especifique la fecha de caducidad deseada y haz clic en el botón "Fijar", ya sea como fecha absoluta (ejemplo "17 de marzo de 2010"), o una fecha relativa a hoy (ejemplo, "dentro de 30 días"). Cuando se aproxime la fecha de caducidad, Password Safe te notificará tras iniciarlo que la contraseñas debe cambiarse, así mismo la entrada se marcará en un color distinto.
    Si eliges "En N días", puedes especificar una caducidad "periódica". Esto hará que se calcule una nueva fecha de caducidad basándose en el número de días indicado y en cuando cambiaste la contraseña de la entrada. Por ejemplo, creas una entrada el 1 de enero e indicas 5 días de caducidad periódica. Recibirás un aviso de que la contraseña caduca el 6 de enero. Si cambias la contraseña el 7 de enero, la nueva fecha de caducidad será el 12 (5 días después de que se fije la contraseña).
  • Para cancelar la caducidad pulsa en "Limpiar".
  • Estadísticas: Estos campos de sólo lectura ayudan a realizar un seguimiento sobre la entrada seleccionada, cúando fue creada, último acceso, etc.
Nota: Password Safe sólo avisará cuándo caduca la contraseña. Es responsabilidad del usuario cambiar la contraseña.


Nombres de usuario y contraseñas

Nombres de usuario, contraseñas y grupos: Política de contraseñas

Nombres de usuario, contraseñas y grupos junto con los parámetros adicionales se gestionan en 4 pestañas:

  • Básico: todos los elementos necesarios para la gestión de contraseñas
  • Adicional: especificaciones adicionales, incluyendo el historial
  • Fechas y horas: caducidad y estadísticas
  • Política de contraseñas: diferencias específicas sobre los valores predeterminados

Pestaña política de contraseñas

Editar/Ver política de contraseñas

Si no quieres usar la política de contraseñas por defecto (ver Fijando la política de contraseñas), puedes definir una politica de contraseñas diferente en esta pestaña, marcando "Usar la siguiente política" y seleccionando los elementos apropiados.


Fijar una política de contraseñas

politica de contraseñas

La politica de contraseñas describe las reglas que se usan para crear una contraseñas—las letras, mayúsculas o minúsculas, longitud y cuaquier carater especial. En algunos casos sólo se requieren letras minúsculas en otros se solicita una letra mayúscula, numeros, o caracteres especiales, así como especificar la longitud mínima. En general, es una buena idea usar la máxima longitud permitida y mezcla de caracteres de todo tipo.

El diálogo de política de contraseñas te permite fijar la política general de generación de contraseñas. Esta politica puede modificarse temporalmente y las contraseñas pueden editarse en cualquier momento en el dialogo Editar/ver entrada.

Seleccionar reglas de contraseñas

Cada elemento "usar" (usar números, usar simbolos, etc.) seleccionado en el diálogo fuerza a que Password Safe incluya los caracteres especificados en las contraseñas que genera. Cada contraseña se generará con la longitud especificada (ni más corto ni más largo). La única excepción es la opción Usar sólo caracteres hexadecimales. Si está seleccionada, las contraseñas incluirán sólo caracteres hexadecimales. Seleccionar esta opción desactiva todas las demás casillas de verificación.

Seleccionando Generar contraseñas pronunciables hará que Password Safe genere una palabra "sinsentido" que debe ser pronunciable, tal como "ingstria", "ringsony", etc. Esto es útil cuando necesitas una contraseña que sea tanto segura como relativamente fácil de recordar sin Password Safe. Eligiendo esta opción user números y/o usar símbolos permitirá reemplazar algunas letras con sus equivalentes, por ejemplo, "E" se reemplaza con "3", "S" con "5", etc.

Los caracteres que se añaden cuando se selecciona usar símbolos son : + - = _ @ # $ % ^ & ; : , . < > / ~ \ [ ] ( ) { } ? ! | a menos que también esté seleccionado usar sólo caracteres de fácil lectura, en cuyo caso los caracteres son sólo: + - = _ @ # $ % ^ & < > / ~ \ ?

Las letras que se usan cuando está marcadao usar sólo caracteres de fácil lectura son: a b c d e f g h i j k m n o p q r s t u v w x y z y A B C D E F G H J K L M N P Q R T U V W X Y, y los números se limitan a 3 4 6 7 8 9.


Historial de contraseñas

Password Safe te permite mantener las últimas contraseñas usadas en una entrada, junto con la fecha en que se fijaron. Esto es útil para seguir las directivas de contraseñas que se requieren en algunos lugares de trabajo, y volver a una contraseña anterior si un cambio no surtió efecto, por alguna razón. El historial de contraseñas está accesible en la pestaña "Adicional" del diálogo Editar entrada.

Historial de contraseñas

Este cuadro de diálogo muestra las últimas contraseñas asociadas a una entrada dada. Para mostrarlas, haga clic en el botón "Historial de contraseñas" en el diálogo Editar/ver entrada. Pueden realizarse las siguientes operaciones:

Mantener N últimas

Si selecciona esta opción, las contraseñas recientes se guardarán con esta entrada. También se puede indicar cuántas contraseñas mantener.
Nota: Desmarcar esta opción no borrará el historial. Sólo hará que Password Safe deje de almacenar mas contraseñas en esta entrada.

Copiar una contraseña

Al hacer clic en una fila en la lista de contraseñas recientes copia la contraseña que aparece en esa fila en el portapapeles.

Borrar historial

Al hacer clic en este botón se borrarán las contraseñas previamente almacenadas con esta entrada.
Nota: La entrada no se modifica realmente hasta que haces clic en el botón Aceptar del diálogo Editar/ver entrada. Si haces clic en Borrar historial por error, haz clic en Cancelar en lugar de Aceptar en el diálogo Editar/ver entrada.

Copiar todo

Al hacer Clic en este botón se copiará toda la lista de historial de contraseñas (fechas y contraseñas) al portapapeles.


Cambiar las contraseñas maestras

Diálodo cambiar contraseñas maestras

Para cambiar una contraseñas maestra ("Combinación de seguridad"), en primer lugar abre la base de datos cuya contraseña deseas cambiar. Una vez abierta, ve al menú Herramientas y selecciona Cambiar contraseña maestra. Debes introducir la contraseña maestra vigente, y después la nueva contraseña maestra (dos veces, para confirmarla). La contraseña maestra puede introducirse con el teclado físico o el virtual.

Password Safe comprueba si la contraseña maestra es débil. Por lo general, una contraseña maestra (como cualquier contraseña) debe estar compuesta de una mezcla de mayúsculas y minúsculas con al menos un numero o carácter especial (como los que se encuentran por encima de las teclas numéricas en el teclado). Si se introduce una contraseña maestra que el programa considera débil, se le solicitará confirmación. Tienes la opción de aceptar la contraseña introducida (débil) o introducir una nueva.

Notas:
  • Password Safe no tiene un mecanismo para recuperar contraseñas de seguridad perdidas u olvidadas.
    Esta es una decisión de diseño deliberada, ya que cualquier mecanismo para recuperar las contraseñas perdidas plantea un agujero de seguridad que pueden ser explotado..
  • Elige una contraseña difícil de adivinar. Una contraseña trivial, como "contraseña" o tu nombre es fácil de adivinar e invalida la seguridad que proporciona Password Safe.


Autoescritura

Autoescritura proporciona una forma de introducir fácil y rápidamente la información de usuario y contraseña. Con un solo clic, el nombre de usuario y contraseña se introducen y envían para validar. Por defecto, la fórmula seguida por las pulsaciones automáticas es como sigue: el nombre de usuario, seguido por un tabulador, seguido por el contraseña, otro tabulador y la tecla Intro(usuario TAB contraseña TAB INTRO). Esto funciona bien en la mayoría de los sitios web que requieren identificación por usuario/contraseña.

Para sitios web o aplicaciones que requiren información diferente, es posible adaptar el comportamiento de autoescritura como se describe en la sección Personalizar autoescritura que aparece mas abajo. También puedes personalizar el texto por defecto de autoescritura a través de la pestaña Misc. en el dialogo Opciones. Este puede ser util si, por ejemplo, la autoescritura es demasiado rápida para tu máquina.

Usando autoescritura

  1. Situa el cursor en el campo usuario del formulario
  2. Maximiza o abre Password Safe
  3. Selecciona una entrada
  4. Ctrl -T or clic derecho y selecciona Realizar autoescritura o haz clic en el botón Autoescritura de la barra de herramientas.

Personalizar autoescritura

Para sitios web o aplicaciones que no tengan el campo de usuario seguido por el campo de contraseña y el botón entrar, puedes modificar el comportamiento rellenando el campo campo "Autoescritura" con texto que especifique el comportamiento deseado:

  • \u se reemplaza por el usuario de la entrada.
  • \p se reemplaza por la contraseñas de la entrada.
  • \g se reemplaza por el grupo de la entrada.
  • \i se reemplaza por el título de la entrada.
  • \o se reemplaza por el contenido del campo notas (puede incluir varias líneas).
    • Cualquier caracter de fin de línea ‘\n’, ‘\r’ o ‘\r\n’ se convierten a ‘\r’ (retorno de carro).
    • No se hacen sustituciones de secuencias de escape dentro del campo Notas (‘\u’, ‘\p’ etc.) excepto la secuencia ‘\t’ que se reemplaza por el caracter tab.
  • \oNNN se reemplaza por el contenido de la enésima línea del campo notas
    • NNN pueden ser de uno a tres dígitos (\o5 para la quinta línea, \o45 para la cuadragésimoquinta, etc.
    • No se incluyen caracteres de fin de línea.
    • Si NNN es mayor que el múmero de líneas del campo notas, no tiene efecto.
    Nota esta es un forma apropiada de soportar autoescritura en aplicaciones que requieren una segunda contraseña u otro texto arbitrario como parte del proceso de identificación.
  • \b se reemplaza por la tecla retroceso.
  • \t se reemplaza por la tecla Tab, saltando un campo.
  • \n se reemplaza por la tecla intro, presionando un botón.
  • \\ se reemplaza por la tecla contrabarra (\).
  • \dNNN fija el retardo entre caracteres en NNN milisegundos, en los lugar de los 10 por defecto. Esto cambia el retardo del actual y subsecuentes caracteres. Por ejemplo, "rápido\d500lento" resultará en 'rápido' escribiéndose con el retardo por defecto, y las letras 'l', 'e', 'n', 't' y 'o' escritas con una pausa de medio segundo antes de cada una. Si quieres fijar un retardo puntual que no afecte la velocidad de los siguientes caracteres, usa '\w' o '\W', como se indica más abajo.
  • \wNNN o \WNNN introduce un retardo de NNN milisegundos para \w, o segundos si se usa \W. Por ejemplo, "como\w500ahora" ocasionará que se escriba 'como' (a la velocidad por defecto o aquella especificada en el último \d), seguido por una pausa de medio segundo, seguida por 'ahora' escrita a la misma velocidad que 'como'). Igualmente, "como\W2ahora" introduce una pausa de 2 segundos entre las dos palabras. Esto es útil para ajustar los tiempos con ciertas páginas web.
  • \z invoca el antiguo mecanismo de autoescritura. Este mecanismo puede manejar incorrectamente caracteres no latimos, pero puede hacer funcionar la autoescritura en ciertos sitios web problemáticos. Si ves que autoescritura no funciona bien en un sitio web en concreto, prueba este código en el campo autoescritura.
  • Todos los demás textos se escriben tal cual.

Ejemplo: Lo siguiente puede usarse para introducir el número de cuenta bancaria (12345) antes del usuario y contraseñas:

12345\t\u\t\p\t\n

Nota: Si tienes problemas con autoescritura, puedes desactivar bloqueadores de popup. Se han reportado problemas con la interacción de bloqueadores de popup con la funcionalidad de autoescritura.


Haciendo y restaurando copias de seguridad

Puesto que la información almacenada en la base de datos de contraseñas es usualmente sensible e importante, Password Safe proporciona varios mecanismos para hacer y restaurar copias de seguridad de la bases de datos. Esta sección describe como hacer copias de seguridad de tu base de datos de contraseñas. Password Safe puede configurarse para hacer copias de seguridad automáticas de tu base de datos cada vez que se guarda. Esas copias de seguriad se llaman copias de seguridad intermedias, y están descritas aquí.

Hacer una copia de seguridad

Crear una copia de seguridad de la base de datos de contraseñas actual.

  1. Pulsar en Hacer copia de seguridad
  2. Selecciona una ubicación para el archivo de respaldo
  3. Pulsa Guardar

Nota: Es muy recomendable que hagas copias frecuentes de tus base de datos de contraseñas. Esto ayudará a salvaguardar la lista de contraseñas ante caídas de sistemas o corrupción de ficheros. La copia de seguridad está encriptada usando la misma contraseñas que la base de datos actual de que se hace la copia de respaldo.

Restaurar desde una copia de seguridad

Restaurar un archivo de base de datos de contraseñas.

  1. Pulsa Restaurar desde copia de seguridad
  2. Ir a la ubicación de la copia de respaldo y seleccioan el archivo a restaurar
  3. Puls Abrir
    Se preguntará por la contraseña.
  4. Introducir la base de datos de las contraseñas y pulsar Abrir
Notas:
  • La base de datos restaurada no se "guarda" con la extensión estandar de base de datos de Password Safe (.psafe3) hastaa que no seleccionas Guardar o Guardar como desde el menú archivo. Se pedirá "Guardar" la base de datos y darle un nombre name si no la has grabado antes de salir de la aplicación.
  • Adicionalmente a la copia y restauración definida aquí, Password Safe guarda una copiad de la base de datos antes de grabar un cambio. La copia se guarda en el mismo directorio de la base de datos actual, con el mismo nombre, excepto la extensión, que es ".ibak" en lugar de ".psafe3". Ver aquí para más información sobre las copias de seguridad automática.


Pestaña copias de respaldo

pestaña copias de respaldo

La pestaña de copias de respaldo te permite configurar como se crean y manejan los copias de seguridad automáticas.

Guardar base de datos inmediatamente tras Editar o Añadir

Estando seleccionado, Password Safe guarda todos los cambios hechos en una entrada automáticamente, sin esperar a que se use el menú Guardar o Guardar como y sin confirmación.

Crear archivos de respaldo intermedios (.bak) antes de guardar

Estando seleccionado, Password Safe copiará la base de datos antes de cada vez que se guarde. Los nombres y ubicación de las copias de respaldo se definen en los siguentes campos, al igual que cuantas copias deben guardarse.

Nombre de copia de respaldo

Los nombres de los archivos de respaldo consisten en Base (por defecto el nombre de la base de datos sin la extensión .psafe3), y Sufijo (nada, un contador o la fecha y hora de la copia de respaldo). Aquí puedes configurar como se nombra al archivo de respaldo, y cuantos se grabarán (Password Safe borrará automáticamente los más antiguos tras el número de archivos de respaldo que indiques). Esto sólo funciona si el sufijo es un número incremental (un contador).

Directorio de respaldo

Por defecto, Password Safe almacena las copias de respaldo en la misma carpeta que la base de datos abierta. En este campo puedes indicar una localización alternativa, como una carpeta especial para copias de seguridad, un disco de red, un llave estraíble, etc. Por supuesto, debes tener permiso de escritura en la ubicación que indiques.


Copias de seguridad a prueba de fallos

Cuando PasswordSafe finaliza normalmente, se te preguntará si hay cambios no guardados en la base de datos. Sin embargo, si cierra la sesión la sesión de Windows, apaga o reiniciar su PC, entonces PasswordSafe pueden no tener la oportunidad de preguntarle (el comportamiento exacto depende del tipo de cierre y la versión de Windows).

En este caso, PasswordSafe intentará realizar una "copia de seguridad a prueba de fallos" (extensión de archivo 'fbak'). Se creará en el mismo directorio que la base de datos actualmente abierta. La base de datos actual y sus "copias de seguridad periódicas" no serán alteradas.

Cuando la base de datos original se vuelve a abrir, PasswordSafe comprobará la existencia de cualquier archivo de copia de seguridad a prueba de fallos y, si lo encuentra, se mostrará un cuadro de diálogo similar al de abajo.

Copia de seguridad a prueba de fallos al abrir

La primera fila es la base de datos especificada seguido de información general al respecto (el mismo que figura en el cuadro de diálogo Propiedades en el menú Archivo). Seguidamente aparece el archivo (o archivos) de copia de seguridad a prueba de fallos. Si se puede abrir con la misma contraseña que la base de datos principal, sus propiedades también se muestran. Si tienen una palabra de paso diferente o no es una base de datos válida, entonces un 'No' se muestra en la columna de la frase de paso y se indican las propiedades.

Tus opciones son las siguientes:

  • Continuar
    Al hacer clic en este botón PasswordSafe ignora todos los archivos de copia de seguridad a prueba de fallos y continua con la base de datos seleccionado actualmente.

  • Seleccionar
    El archivo de copia de seguridad a prueba de fallos seleccionado se abre en lugar de la base de datos seleccionada actualmente.

  • Eliminar
    Esto eliminará el archivo de copia de seguridada prueba de fallos seleccionado. Si Windows es compatible con una papelera de reciclaje en este medio (por lo general sólo discos locales), será trasladado allí. Si no, se eliminará de forma permanente.

  • Salir
    Si esta es la primera base de datos abierta en la puesta en marcha de PasswordSafe, PasswordSafe saldrá. Si no, se cancelará la apertura y la base de datos abierta previamente, en su caso, se mantendrá abierta.

  • Ayuda
    Muestra este tema de ayuda.

Sugerencias:

  • Si no sabes elegir, continua con la base de datos actual y usa la función de comparar desde el menú Archivo para mostrar las diferencias con la copia de seguridad a prueba de fallos.
  • Si abres una copia de seguridad a prueba de fallos y has decidido que es la versión que deseas conservar, debes guardarla como una base de datos normal. Cuando lo hagas, considera cambiar primero el nombre del original o guarda la copia de seguridad a prueba de fallos con un nombre completamente nuevo.
  • Una vez que estés satisfecho de haber recuperado la base de datos correcta, ya sea el original o una copia de seguridad a prueba de fallos, debes borrar las viejas copias de seguridad a prueba de fallos para que no se te pregunte de nuevo con posterioridad. Nota: Si utiliza este cuadro de diálogo para eliminar estos archivos, se enviarán a la papelera de reciclaje, si tu versión de Windows es compatible con el medio que los contenga.

Nota: No hay nada que NINGUNA aplicación pueda hacer para guardar la información si se apaga el PC, se queda sin batería o el procesador, el disco duro o cualquier otro componente falla. Al igual que con todos tus datos importantes, debes hacer una copia de seguridad a otro medio regularmente. Este podría ser un pen drive USB, discos duros externos, unidades de red, CD o DVD, etc. Estas copias de seguridad se deben almacenar en un lugar seguro.


Importar entradas

Password Safe te permite importar información de contraseñas de otros formatos. Estos archivos pueden haber sido generados por otras aplicaciones, exportados de una hoja de cálculo, o incluso escritos a mano con el bloc de notas o un editor de texto similar.

Los formatos soportados por Password Safe son:

  • Texto
  • XML
  • KeePass (otra utilidad de gestión de contraseñas)

Formato texto

Los archivos de texto utilizados para importar las entradas de contraseñas constan de una o más entradas contraseña. Cada campo dentro de una entrada está separada por un separador de campo y cada entrada puede consistir en una o más líneas. Detalles sobre el formato esperado del archivo de texto a importar puede encontrarse en la sección "Formato de importación y exportación como texto sin formato".

Diálogo opciones de importación de texto

El separador de campo utilizado en el archivo de texto importado y un nombre de grupo predeterminado para importar las nuevas entradas pueden configurarse en antes de procesar el archivo.

Opciones de importación de texto

  1. Archivo > Importar de....
  2. Seleccionar Texto sin formato...
  3. Fijar los parametros y opciones para importar el archivo de texto
  4. Si se ha utilizado un carácter delimitador de líneas en el campo notas, ya sea en una exportación previa o con un editor de texto, introdúzcalo aquí para que, durante el proceso de importación, el campo de notas se divide en varias líneas mediante la sustitución de este caracter por un nueva línea.
  5. Pulsa Aceptar
  6. Selecciona el archivo de texto a importar.
  7. Al final del proceso de importación, aparece un pequeño cuadro de diálogo mostrando cuántas entradas se han añadido, y cuántas (en caso de haberlas) se analizaron sin éxito.
IMPORTANTE: La primera línea del archivo que se importa debe ser una lista separada por tabulaciones de los nombres de los campos que contiene cada entrada, por ejemplo "Grupo/Título Usuario Contraseña URL", etc. Esta línea se genera automáticamente por la función "Exportar texto", pero debe añadirse manualmente para archivos creados con otras herramientas.

XML

XML (eXtensible Markup Language) es un formato popular de trasferencia de datos entre aplicaciones. Password Safe puede importar archivos XML que se generasen de acuerdo al esquema definido en el archivo pwsafe.xsd, que se proporciona como parte de la distribución.


Exportar entradas

Password Safe permite exportar (e importar) las contraseñas almacenadas a varios formatos. Para exportar datos utiliza el menú Archivo->Exportar a. Los formatos soportados son:

  • Password Safe v1 (para usar con las versiones 1.x de Password Safe)
  • Password Safe v2 (para usar con las versiones 2.x de Password Safe)
  • Texto sin formato
  • XML

Para versiones previas de Password Safe, selecciona el formato deseado e indica el nombre del archivo de base de datos que quieres crear.

Exportar a texto

Nota: El texto exportado es una copia desprotejida de las entradas seleccionadas. Borrar esta copia tras su uso no es suficiente para hacerlo inaccesible a un atacante determinado, de hecho pasa por alto la seguridad del programa.
Por favor NO utilices esta función a menos que entiendas y aceptes los riesgos.

Password Safe te permite exportar entradas de contraseñas a archivos de texto. Estos archivos pueden ser utilizados y modificados por otras aplicaciones.
Antes de exportar la base de datos a un archivo de texto plano sin encriptar se te pedirá que introduzcas la contraseña maestra o combinación de seguridad.

Exportar a texto

Puedes indicar algunas opciones:

  • Las entradas de contraseñas se exportan con un tabulador entre campos, esto es, entre los campos grupo.título, usuario, contraseñas y notas. "Grupo.título" se considera un único campo. Todd campo que contenga un espacio en blanco se delimitará con comillas dobles. Sólo el campo notas puede contener entradas con varias líneas. El tratamiento normal consiste en colocar cada línea de notas en una línea independiente en el campo de texto exportado. Sin embargo, esto hace que sea difícil ordenar o comparar dos archivos exportados diferentes. Puedes especificar un delimitador para separar las líneas múltiples al exportalo. Si vas a importar un archivo de texto creado con un delimitador, entonces debe ser especificado, todas las líneas de notas aparecerá como una sola línea en la base de datos resultante.
    Si es necesario, marca que quieres poner por separado todas las líneas en el campo notas en una línea e introduzca el carácter que se utiliza como delimitador. Puesto que todo el campo notas está encerrado entre comillas dobles, no se puede seleccionar este caracter como delimitador de líneas.

  • Tienes más control sobre el formato de exportación haciendo clic en "Opciones avanzadas". Aparecerá el siguiente cuadro de diálogo:

Opciones avanzadas de exportación a texto

Este cuadro de diálogo te permite exportar sólo algunas de las entradas, filtrar por el texto de un determinado campo, y/o especificar los campos que se van a exportar. Haga clic en Aceptar cuando hayas terminado, o en Cancelar para volver al cuadro de diálogo de exportación de texto sin ningún cambio.

A continuación se te pedirá que proporciones el nombre del nuevo archivo y confirmar sobrescribir un archivo del mismo nombre si ya existe en el directorio especificado.

Nota: Los detalles sobre el formato del archivo de texto exportados se pueden encontrarse en la sección "Formato de exportación e importación de texto sin formato".

XML

XML (eXtensible Markup Language) es un formato popular para transferir datos entre aplicaciones. Password Safe puede exportar (e importar) entradas de la base de dato en este formato. La estructura (o esquema) con la que los datos se exportan y validan se define en el archivo pwsafe.xsd, que se proporciona como parte de la distribución. Este archivo es utilizado por Password Safe al importar datos XML, y debe proporcionarse a las aplicaciones que deseen utilizar los datos exportados.
Nota: El texto exportado es una copia desprotejida de las entradas seleccionadas. Borrar esta copia tras su uso no es suficiente para hacerlo inaccesible a un atacante determinado, de hecho pasa por alto la seguridad del programa.
Por favor NO utilices esta función a menos que entiendas y aceptes los riesgos.
 La visualización de los archivos XML se especifica mediante pwsafe.xsl - un archivo de eXtensible Stylesheet Language. Un archivo de ejemplo, que puede ser modificado para sus propias necesidades, se suministra como parte de la distribución. Este archivo es sólo un ejemplo y puede modificarse fácilmente para mostrar los campos que quieras mostrar. Dado que sólo muestra los datos y no los altera, todavía podrás importar a Password Safe posteriormente.

Como con las opciones de exportar a texto plano, puedes controlar que entradas y campos exportar al archivo XML pulsado en el botón Avanzadas del diálogo exportar a XML. Esto mostrará el siguiente cuadro de diálogo:
Opciones avanzadas de exportación a XML

Este cuadro de diálogo te permite exportar sólo algunas de las entradas, filtrar por el texto de un determinado campo, y/o especificar los campos que se van a exportar. Haga clic en Aceptar cuando hayas terminado, o en Cancelar para volver al cuadro de diálogo de exportación de texto sin ningún cambio. Ten en cuenta que el esquema XML requiere el título y campo de contraseña, por lo tanto, estos no pueden ser deseleccionados.

A continuación se te pedirá que proporciones el nombre del nuevo archivo y confirmar sobrescribir un archivo del mismo nombre si ya existe en el directorio especificado.


Filtros

Un "filtro" es un criterio (o conjunto de criterios) con que una entrada coincide o no. PasswordSafe te permite definir filtros, y mostrar sólo aquellas entradas que coincidan con un filtro dado. Puedes definir un filtro para consultar una sola vez, o puedes definir varios filtros, nombrarlos y almacenarlos, por usarlos reiteradamente. Los filtros pueden almacenarse junto con la base de datos, o externamente, para compartir el mismo filtro a través de varias bases de datos.

Definir un filtro

Para definir un nuevo filtro, selecciona el menú Ver->Filtros->Nuevo/Editar Filtro. Se mostrará el siguiente cuadro de diálogo:
Diálogo filtro de visualización

Como puedes ver, cada filtro está compuesto de una o más filas, donde cada fila define un criterio sobre un campo determinado. Las condiciones definidas en cada fila puede ser enlazadas con "y" u "o" con las condiciones definidas en la fila anterior. Esto te permite definir los siguientes tipos de filtros:
1. Todas las entradas cuyo usuario contiene "jose" or "José" or "JOSÉ"
example1
2. Todas las entradas con usuario "José" (exactamente) creado tras el 5 de mayo de 2010
example2
3. Todas la entradas cuyo usuario contenga "José" or "María"
example3

Como puedes ver, los filtrol pueden tener cualquier complejidad.

Las columnas de la tabla filtro son las siguientes:
  • '#' - Este es el número de fila. Se muestra por conveniencia y no se puede modificar.
  • '?' - La casilla de verificación en esta columna determina si la fila está activa o no. Sólo se usan las filas activas al aplicar el filtro. Hacer click en la casilla activa/desactiva la fila.
  • '+' - Clic para insertar una nueva fila por debajo de una fila determinada.
  • '-' - Click para eliminar la fila actual. Nota: Puesto que borrar una fila es permanente, es posible que desees deshabilitarlo.
  • 'Y/O' - Esto te permite determinar la relación de la regla que está añadiendo con la regla anterior.
  • 'Campo' - Selecciona el campo de la entrada que te interesa, usuario, grupo, notas, etc.
  • 'Criterio' - Define el valor que le interesa para el campos seleccionado. Una vez hayas seleccionado un campo, al hacer clic en este abrirá un cuadro de diálogo que permite especificar los criterios, que se muestran en la tabla.

Aplicar un filtro

Una vez que has definido el filtro, al hacer clic en 'Aplicar' se aplicará el filtro en las entradas de la base de datos, al tiempo que deja el diálogo de ajustar filtro de visualizacion abierto. Esto es útil para fijar y refinar un filtro en base a los resultados. Pulsando en 'Aceptar' también se aplica el filtro, pero se cierra el diálogo de ajustar filtro.

Administrar filtros

Fijar/editar un filtro es una buena forma de trabajar con filtros en tareas de una sóla vez. Si ves que tienes varios filtros que quieres utilizar repetidamente, entonces puedes almacenarlos y administrarlos a través del diálogo Ver->Filtros-> Administrar...
Administrar filtros

El cuadro de diálogo administrar filtros tiene dos tablas. La tabla superior muestra los filtros, y las tabla inferior el contenido del filtro seleccionado.
  • Para añadir un nuevo filtro, haz clic en Nuevo. Esto es equivalente a seleccionar el menú Ver->Filtros->Nuevo/editar filtro.
  • Para editar un filtro existente, selecciónelo y haga clic en Editar.
  • Para aplicar un filtro existente, haga clic en la casilla Aplicar en la fila el filtro deseado. Ten en cuenta que sólo puede aplicarse un filtro en un momento dado.

Almacenar filtros

Los filtros pueden ser almacenados como parte de la base de datos actual o, externamente, como archivos XML. Almacenar filtros externamente aes una buena forma de compartir filtros entre bases de datos, mientras que almacenarlos como parte de la base de datos asegura que información potencialmente sensible de la definición de los filtros está protegida.
  • Para almacenar los filtros en un archivo externo: Fija la opción Exportar de los filtros que desea almacenar externamente, a continuación, haga clic en el botón Exportar.
  • Para almacenar los filtros de la base de datos actual: Fija la opcion Copiar a la BD y pulsa el botón copiar.
  • Para cargar un filtro externo: Haz clic en el botón Importar.
Nota:
Al iniciar PasswordSafe busca un archivo llamado autoload_filters.xml en el mismo directorio que el archivo pwsafe.cfg (por defecto el directorio donde está instalado PasswordSafe). Si existe tal archivo, entonces es automáticamente importado y los filtros que contiene están listos para su uso. Esto es útil si tienes una serie de filtros que deseas compartir entre varias bases de datos, sin tener que importarlos de forma explícita cada vez.


Argumentos de línea de comandos

Argumentos de la línea de comandos

Ejecutar Password Safe sin argumentos hace que se pregunte por la contraseña maestra de la última base de datos que se abrió, o por la contraseña maestra de una nueva base de datos si nunca fue abierta una en tu máquina (por ejemplo, la primera vez que utilizas Password Safe). Es posible modificar esto ejecutando Password Safe como sigue:

  • pwsafe basededatos
    Esto abrirá el archivo de base de datos especificado en lugar del último abierto. Si se indica un nombre de archivo, sin trayectoria, se buscará en el directorio en que se llama a la aplicación. Si el nombre de archivo y/o trayectoria contienen espacios deben encerrarse entre dobles comillas.
  • pwsafe -r [basededatos]
    Esto abrirá la base de datos especificada en modo sólo lectura. Si no se indica base de datos, la aplicación preguntará por ella, y será abierta en modo sólo lectura.
  • pwsafe -v basededatos
     Esto validará la base de datos tras la introducción de la contraseñas maestra, corrigiendo las inconsistencias que sean necesarias. Bastante útil cuando se trabaja con bases de datos escritas por otras aplicaciones.
  • pwsafe -e nombrearchivo
    Preguntará por una contraseña y encriptará el fichero con una clave derivada de esa contraseña. Nota: El archivo puede ser cualquiera. El archivo encriptado tendrá el nombre del archivo original, con ".PSF" añadodo a el.
  • pwsafe -d nombrearchivo
    Preguntará por una contraseña y desencriptará el archivo con una clave derivada des esa contraseña. Nota: Esto sólo funciona en archivos que fueron encriptados ejecutando pwsafe con la opción '-e' (ver arriba).
  • pwsafe -c
    Esto iniciará la aplicación cerrada, esto es, sin ninguna base de datos y sin el diálodo inicial de apertura (Para acceder a una base de datos usa el menú Archivo).
  • pwsafe -s [basededatos]
     Iniciará la aplicación "silenciosamente", esto es, minimizada y sin base de datos (salvo que se especifique una). Cuando la aplicación se pasa a primer plano, se presenta el dialodo de apertura (Esta opción es útil para iniciar la aplicación al iniciar sesión, a través de un atajo en la carpeta Inicio del usuario). Nota: Esto pone la apliación implicitamente en la bandeja de notificación.
  • pwsafe -m
    Esta es la misma opción que '-c', con el añadido de que la aplicación se inicia minimizada.
Adicionalmente, se aceptan las siguientes opciones:
  • -u usuario
    Hace que la aplicación lea y escriba las preferencias del usuario espeficado, en lugar de usar el del usuario de la sesión.
  • -h hostname
    Hace que la aplicación lea y escriba las preferencias del equipo, en lugar del nombre de la máquina.
  • -g archivo_configuración
    Hace que se use el archivo especificado para leer y guardar las preferencias, en lugar del archivo por defecto pwsafe.cfg. Si sólo se indica en nombre del archivo, sin trayectoria, se buscará en el directorio en que se llama a la aplicación. Si el nombre de archivo y/o trayectoria contienen espacios deben encerrarse entre dobles comillas.
Estos puede ser útiles si quieres compartir las mismas preferencias en distintas máquinas, por ejemplo, al ejecutar Password Safe desde una llave portátil.


Menú archivo

El menú archivo contiene opciones relacionadas con el manejo y creación de nuevas bases de datos de Password Safe.

Nuevo

Crea una nueva base de datos de contraseñas.

Abrir

Abre una base de datos de contraseñas existente.

Cerrar

Cierra la base de datos abierta sin salir de la aplicación.

Recientes

Esta sección del menú archivo lista las bases de datos abiertas recientemente. Esta sección estará vacía si es la primera vez que se usa Password Safe.

Notas:

  • La lista de archivos abiertos recientemente puede limpiarse seleccionando "Limpiar archivos recientes"
  • El número de archivos recientes que mostrará Password Safe puede configurarse en el diálogo Herramientas->Opciones->Sistema, donde también puedes elegir si prefieres ver los archivos recientes en el menú archivo, o como un submenú.

Guardar

Guardar cualquier cambio en la caja de seguridad actual. Si no se han hecho cambios desde la anterior vez que se guardó, o si la base de datos se abrió como sólo lectura, esta opción estará desactivada.

Guardar como

Guarda una copia de la caja de seguridad actual con un nuevo nombre o ubicación.

Exportar a

Exporta el contenido de la base de datos actual a un archivo externo en un formato de base de datos anterior de Password Safe, XML, o como texto. Aquí tienes más información sobre importar y exportar la base de datos a otros formatos.

Importar de

Importa el contenido de una base de datos exportada anteriormente o un archivo de texto correctamente formateado, XML, o una base de datos KeePass, en la base de datos actual. Aquí tienes más información sobre importar archivos de texto.

Combinar

Combina una base de datos Password Safe o un archivo que copia de seguridad (.bak) con la base de datos actual. Desabilitado en modo sólo lectura.

Comparar

Compara la base de datos abierta con otra.

Sincronizar

Sincroniza la base de datos abierta con otra.

La principal diferencia entre Combinar y Sincronizar es que durante la combinación, todos los elementos de la base de datos que se mezcla se llevan a la base de datos abierta. En una sincronización, sólo los elementos de la base de datos abierta se actualizarán.

Nota: Las operacione de combinar, comparar y sincronizar pueden llevar mucho tiempo, especialmente en bases de datos grandes.

Propiedades

Muestra información de la base de datos abierta, como: versión del formato, número de grupos, número de entradas e información sobre cuándo y quién realizó la última grabación.

Salir

Cierra el programa Password Safe. Si se hicieron cambios desde la última vez que se guardó la base de datos, se te preguntará si quieres guardarlos.


Menú editar

Entrada | Alias | Grupo
Menú editar entrada | Menú editar alias | Menú editar grupo

A través del menú editar puedes añadir, editar, usar y organizar nombres de usuario y contraseñas. Ten en cuenta que el contenido de este menú cambia de acuerdo a lo que está seleccionado en la vista principal (por ejemplo, si has seleccionado una entrada o un grupo). Además, algunos elementos pueden estar desactivados, como se indica a continuación.

Añadir entrada

Añada un nuevo usuario y contraseña. Deshabilitado si la base de datos se abre en modo sólo lectura.
Para más información ver Nombres de usuario, contraseñas y grupos.

Editar entrada / Expandir/contraer grupo

Cuando está seleccionada una entrada, edita la misma. Cuando está seleccionado un grupo (en vista de árbol), expande o contrae las entradas contenidas dentro del grupo. Editar una entrada está deshabilitado si la base de datos se abre en modo sólo lectura.
Para más información ver Nombres de usuario, contraseñas y grupos.

Eliminar entrada / Eliminar grupo

Cuando se selecciona una entrada, esta se borrará. Cuando se selecciona un grupo (en vista de árbol), borrará todas las entradas bajo el grupo seleccionado. Se pide confirmación si hay más de una entrada en el grupo seleccionado. Está deshabilitado si la base de datos se abre en modo sólo lectura.

Renombrar entrada / Renombrar grupo

Renombra la entrada seleccionada (o grupo, en vista de árbol). Está deshabilitado si la base de datos se abre en modo sólo lectura.

Buscar

Busca una entrada que contenga el texto dato. Por defecto se busca en todos los campos excepto la contraseña.
Para más información ver Buscar un texto.

Duplicar entrada

Duplica la entrada seleccionada. Está deshabilitado si la base de datos se abre en modo sólo lectura.

Añadir grupo

Crea un nuevo grupo de contraseñas (por ejemplo, Contraseñas de bancos). Está deshabilitado si la base de datos se abre en modo sólo lectura.

Deshacer

Se deshace la última acción. Repetir deshacer deshace las acciones en el orden inverso, de la última a la primera.

Rehacer

La última acción deshecha se ejecuta de nuevo.

Limpiar portapapeles

Limpia la memoria del portapapeles. Elimina del portapapeles cualquier cosa que se pegase allí por Password Safe (contraseña, usuario, notas, etc.). Si el contenido actual del portapapeles no proviene de Password Safe, no tendrá efecto.

Copiar contraseña al portapapeles

Copia la contraseña de la sección actual al portapapeles.

Mostrar parte de la contraseña

Esta acción muestra una ventana que te permite indicar qué caracteres de la contraseña mostrar. Esto el útil para sitios que preguntan por parte de la contraseña para iniciar sesión. Por ejemplo, la contraseña podría ser "qAdm3ddENc", y te podrían preguntar que introdujeses la primera, tercera, quinta y octava letras. Esta ventan te permitie hacer esto de una forma conveniente: Introduce en el campo superior las posiciones de los caracteres que quieres como subconjunto de la contraseña. Puedes usar espacios, comas o punto y coma para separar las posiciones. Los caracteres correspondientes de la contraseña se muestran en el campo inferior. Para salir, pulsa la tecla Esc.

Copiar usuario al portapapeles

Copia el usuario de la selección actual al portapapeles.

Copiar notas al portapapeles

Copia el contenido del campo notas de la sección actual al portapapeles.

Copiar URL al portapapeles

Copia el campo URL de la sección actual al portapapeles.

Copiar correo al portapapeles

Copia el campo correo de la sección actual al portapapeles.

Copiar al portapapeles ejecutar comando

Copia el campo ejecutar comando de la sección actual al portapapeles.

Abrir URL

Cuando está seleccionada una entrada, y esta tiene una URL asociada esto ejecutará el explorador por defecto con la URL. Si no se ha seleccionado una entrada o el campo URL de la entrada seleccionada está vacío, este comando estará deshabilitado.

Ir a URL + Autoescritura

Cuando está seleccionada una entrada, y esta tiene una URL asociada esto ejecutará el explorador por defecto con la URL. Si no se ha seleccionado una entrada o el campo URL de la entrada seleccionada está vacío, este comando estará deshabilitado.

Automáticamente introduce el usuario y contraseñas en el campo de entrada seleccionado.
Para más información ver autoescritura.

Enviar correo

Prepar un correo para enviarse con la información del campo correo de la actual selección.
Para más información ver Nombres de usuario, contraseñas y grupos.

Realizar autoescritura

Introduce automáticamente el usuario y contraseña en el campo de entrada seleccionado.
Para más información ver autoescrituraType.

Ejecutar comando

Esto ejecutará el comando del campo Ejecutar Cmd de la entrada seleccionada.
Para más información ver Ejecutar comando.

Crear atajo

Cuando se selecciona una entrada, esto le permite crear una referencia a la entrada, por lo general en otro grupo. Esto es útil si tiene una entrada que "pertenece" a más de un grupo, pero no desea repetir los datos. Un acceso directo tiene un icono distinto asociado, atajo, y por defecto tiene el nombre "atajo a x", donde x es el título de la entrada original. Por supuesto puedes editar el nombre, mover o borrar el atajo, como cualquier entrada normal.

Ir a la entrada base

Este elemento sólo aparece en un atajo o alias. Tras pulsar Ir a entrada base se seleccionará la correspondiente entrada base.

Editar entrada base

Este elemento sólo aparece en un atajo o alias. Tras pulsar Editar entrada base puedes editar la entrada base correspondiente a este atajo o alias.

Exportar entrada a texto sin formato

La entrada seleccionada se exportará como texto sin formato. Antes de exportar, se te preguntará la contraseñas maestra como confirmación, que pretendes exportar un elemento de la base de datos a un archivo de texto no encriptado.
Para más información ver Exportar entradas.

Exportar entrada a formato XML

La entrada seleccionada se exportará en formato XML. Antes de exportar, se te preguntará la contraseñas maestra como confirmación, que pretendes exportar un elemento de la base de datos a un archivo XML encriptado.
Para más información ver Exportar entradas.

Acciones del botón derecho del ratón

Todas las funciones del menú Editar pueden realizarse también pulsando el botón derecho del ratón sobre la correspondiente entrada, alias o grupo.

Entrada | Alias | Grupo
Menú contextual de entrada | Menú contextual de alias | Menú contextual de grupo

Toda la funcionalida se describe en la sección previa.


Menú ver

El menú ver controla las opciones de visualización disponibles. Puedes cambiar la forma en que se organizan los nombres de usuario y contraseñas de tus entradas: ya sea como una lista única (Lista plana) u organizado por categorías (Árbol jerarquizado). Puedes elegir si se muestra o no una barra de herramientas y en tal caso si se usan los iconos clásicos o nuevos. La propia barra de herramientas se puede personalizar. También puedes expandir o contraer todos los grupos que se muestran en la vista árbol jerarquizado, filtrar las entradas que se muestran según cualquier criterio, seleccione la fuente en la que se muestran las entradas y mostrar informes de combinar, comparar, importación y otras funciones avanzadas.

Cambiar entre las vistas de árbol jerárquico y lista plana

  1. Ir al menú Ver
  2. Seleccionar Lista plana o Árbol jerárquico

Controlando las barras de herramientas

Para mostrar u ocultar la barra de herramients, marca o desmarca el menú Barra de herramientas visible.
Para usar los iconos "nuevos" o "clasicos", selecciona el menú "Nueva barra de herramientas" o "Barra de herramientas clásica", respectivamente.

La "barra de arrastre" es una barra de herramientas especial que te permite pegar partes de la entrada seleccionada "arrastrando" el icono que especifica la parte que deseas pegar a la ventana en que deseas pegarlo. Por ejemplo, para pegar el texto "Notas" de una entrada dada a otra aplicación utilizando la barra de arrastre, selecciona la entrada y, a continuación, arrastra la "N" desde la barra de arrastre a la aplicación. Al soltar el botón izquierdo del ratón, el contenido del campo Notas se pegará en la aplicación. Los iconos de la barra de arrastre se desactivarán ("en gris") para los campos que están vacíos para una entrada dada.
Para mostrar u ocultar la barra de arrastre, marca o desmarca el menú Mostrar barra de arrastre.

Expandir todo

Expande todos los grupos, haciendo visibles todas las entradas (sólo en vista de árbol jerarquizado).

Contraer todo

Contrae todos los grupos (sólo en vista de árbol jerarquizado).

Refrescar F5

Refresca la pantalla haciendo clic en F5 o en este elemento de menú.

Mostrar cambios no guardados

Si está desmarcada la opción Guardar base de datos inmediatamente tras editar o añadir del menú Herramientas => Opciones => Copias de respaldo, los elementos modificados no se guardarán, pero se mostrarán coloreados. Ver la siguiente imagen

Datos con cambios
Listado de todas las entradas.

Al marcar este elemento, sólo se mostrarán los elementos con cambios.

Datos, sólo cambios
Listado de todas las entradas cambiadas.

Nota: Mientras haya cambios que no haya guardado, habrá un "*" en la fila de estado.

Filtros

Un "filtro" es un criterio (o conjunto de criterios) con que una entrada coincide o no. PasswordSafe te permite definir filtros y muestra sólo las entradas que coinciden con un filtro determinado. Tienes más información sobre cómo definir y usar filtros aquí.

Cambiar fuente

Selecciona una fuente diferente para mostrar las entradas en la vista de lista o de árbol, y para mostrar las contraseñas en el diálogo agregar y editar entrada.

Informes

Muestra los resultados de las operaciones de combinar, comparar, importar y validar.


Menú herramientas

El menú herramientas es donde se controlan todas las opciones de Password Safe.

Cambiar contraseña maestra

Seleccionar esta opción abre el dialogo de de cambiar contraseña maestra.
Ver Chambiar las contraseñas maestras para más información.

Hacer copia de seguridad

Crea una copia de seguridad de la base de datos actual.
Ver Haciendo y restaurando copias de seguridad para más información.

Restaurar desde copia de seguridad

Restaura una base de datos de contraseñas desde una copia de seguridad.
Ver Haciendo y restaurando copias de seguridad para más información.

Opciones

Al seleccionar Opciones se abre un dialogo con puestañas donde pueden consultarse y editarse muchas de las opciones de configuración de Password Safe. Para aprender más sobre una pestaña específica selecciónala más abajo:

Pestaña copias de respaldo
Pestaña visualizar
Pestaña seguridad
Pestaña sistema
Pestaña política de contraseñas
Pestaña historial de contraseñas
Pestaña Misc
Pestaña atajos
Nota:
Muchas de las opciones se guardan como preferencias, como se describe aquí.

Validar

Tras seleccionar una base de datos, se comprobará que es completamente compatible con PassowrdSafe.
Nota: Esta opción de menú sólo estará habilitada si no hay abierta ninguna base de datos.

Personalizar barra de herramientas principal

Te permite seleccionar que comandos aparecen en la barra de herramientas y en que orden.

Generar contraseña

Te permite generar una contraseña con la política de contraseñas especificada y ponerla en el portapapeles, pulsando Generar. La contraseñas en el portapapeles puede usarse por alguna otra aplicación.


Menú ayuda

El Menú ayuda da acceso a recursos diversos sobre Password Safe.

Obtener ayuda (F1)

Abre este archivo de ayuda.

Visitar el sitio web de Password Safe...

Abre la pagina de inicio de Password Safeen un explorador.

Acerca de Password Safe

Esta opción abre un diálogo que muestra el número de versión y el aviso de derechos de autor, así mismo te permite comprobar si hay una versión más moderna de Password Safe disponible. Por seguridad, Password Safe cerrará tu base de datos antes de conectarse a Internet para comprobar si hay una nueva versión.

diálogo acerca de Password


Menu barra de herramientas

Hay dos vistas diferentes disponibles para los iconos de barra de herramientas: nuevos y clásicos. Cada uno de los iconos visibles en la barra de herramientas proporciona consejos emergentes. Simplemente mueva el puntero del ratón sobre el icono y aparecerá un pequeño consejo. Para mayor comodidad, se proporciona una referencia rápida para cada uno de los iconos.

Puedes personalizar (a partir de la versión 3.11) los iconos que aparecen en la barra de herramientas y el orden en que aparecen.

Cambiar entre las vistas de iconos

  1. Ir al menú Ver
  2. Seleccionar Barra de herramientas clásica o Nueva barras de herramientas

Lista de iconos

Clásico | Nuevo | Presel. | Descripción
 |  | X | Crea una nueva caja de seguridad para introducir contraseñas.
 |  | X | Abre un diálogo para abrir o cambiar a otra caja de seguridad.
 |  | X | Cierra la caja de seguridad actual.
 |  | X | Guarda cualquier cambio hecho a la caja de seguridad actual.
 |  |  | Guarda los cambios en otra caja de seguridad.
 |  | X | Copia la contraseñas de la entrada seleccionada al portapapeles.
 |  | X | Copia el usuario de la entrada seleccionada al portapapeles.
 |  | X | Copia las notas de la entrada seleccionada al portapapeles.
 |  | X | Borra la memoria del portapapeles.
 |  | X | Realiza autoescritura con la entrada seleccionada.
 |  | X | Va a la URL de la entrada.
 |  |  | Va la URL de la entrada y realiza autoescritura.
 |  | X | Añade una nueva entrada a la caja de seguridad abierta.
 |  | X | Abre la entradas seleccionada para edición.
 |  | X | Borra la entrada seleccionada.
 |  |  | Conmuta entre vistas de lista y árbol.
 |  | X | Contrae todos los grupos abiertos (vista árbol).
 |  | X | Expande todos los grupos (vista árbol).
 |  |  | Compara la base de datos actual con otra.
 |  |  | Combina la base de datos actual con otra.
 |  |  | Exporta datos a un archivo de texto.
 |  |  | Exporta datos a un archivo XML.
 |  |  | Import datos desde un archivo de texto.
 |  |  | Importa datos desde un archivo XML.
 |  |  | Ver informes de las operaciones de importar o combinar.
 |  | X | Opciones de configuración.
 |  | X | Abre este archivo de ayuda.
 |  |  | Ejecuta el comando.
 |  |  | Muestra parte de la contraseña.
 |  |  | Administra filtros.
 |  |  | Edita un filtro.
 |  |  | Aplica un filtro.
 |  |  | Muestra la barra de búsqueda.
 |  |  | Envía un correo.
 |  |  | Sincroniza la caja de seguridad actual con otra.
 |  |  | 'Deshace' la última acción.
 |  |  | 'Rehace' la última acción 'deshecha'.


Pestaña visualizar

Las funciones de la Pestaña visualizar controla como se muestra Password Safe y las entradas de contraseñas.

Mantener Password Safe siempre visible

Estando seleccionado, Password Safe estará siempre sobre el resto de ventanas mostradas si no está minimizado, sin importar que ventana tiene el foco.

Mostrar usuario en vista de árbol

Estando seleccionado, los nombre de usuario se mostrarán entre corchetes siguiendo al nombre del elemento en la vista árbol jerarquizado.

Mostrar contraseñas en vista de árbol

Estando seleccionado, las contraseñas se mostrarán entre llaves siguiendo al nombre de usuario en la vista árbol jerarquizado.
Esta opción está altamente desaconsejada en entornos donde otros pueden ver el monitor.

Mostrar notas como menú desplegable en vistas en árbol y lista

Estando seleccionado, se mostrarán las notas al señalar un elemento.

Mostrar contraseña en agregar y editar

Estando seleccionado, las contraseñas en el dialogo añadir y editar/ver entrada serán visibles por defecto. Puedes mostrar u ocultar la contraseña de una entrada pulsando el botón "Mostrar/Ocultar".

Mostrar notas al editar

Estando seleccionado, las notas se mostrarán por defecto en el dialogo editar. Si no lo está, debes hacer clic en el campo notas para ver el texto que contiene.

Ajuste de línea en notas al añadir y editar

Estando seleccionado, las palabras se ajustarán automáticamente en la ventana, sin barra de desplazamiento horizontal.
Si no está seleccionado, aparecerá una barra de desplazamiento horizontal si es necesario.

Mostrar líneas de cuadrícula en la vista de lista

Estando seleccionado, se mostrará una línea de cuadrícula en la lista, haciendo que parezca una hoja de cálculo.

Poner grupos primero en vista de árbol

Por defecto, las entradas se muestran en orden alfabético en la vista de árbol. Cuando se selecciona esta opción, todos los grupos se mostrarán primero (en orden alfabético), seguido por el resto de entradas del nivel superior.

Resaltar entradas modificadas

Mientras las entradas modificadas no se han guardado, aparecerán resaltadas. Si has seleccionado "Guardar base de datos inmediatamente tras editar o añadir" en la pestaña copias de respaldo, las entradas nunca se resaltarán ya que se guardan inmediatamente.

Avisar N días antes que las contraseñas caduquen

Estando seleccionado, PasswordSafe revisará todas las entradas al cargar la base de datos y mostrará una lista de aquellas cuya fecha de caducidad es N dias o menos desde la fecha actual.

Vista inicial en árbol

Determina que las entradas se mostrarán en vista de árbol al abrir la base de datos.

Icono inicial en área de notificación

Esto le permite cambiar el color del icono de la bandeja del sistema que aparece cuando Password Safe arranque por primera vez y cuando no hay base de datos abierta.


Pestaña Misc.

Varios valores por defecto del programa se muestran en la pestaña Misc.

Confirmar borrado de elementos

Estando seleccionada, se mostrará un mensaje de confirmación cada vez que se intente borrar una entrada de la base de datos.

Registro de últimos accesos

Estando seleccionada, Password Safe registra la hora en que se accede a cada entrada (cuando se copió la contraseñas o cuando se vieron los detalles de la entrada, etc.). La hora se almacena con la entrada y puede consultarse en el diálogo de la entrada.
Notas:
  • Estando habilitado, la base de datos se modificará sin que se edite una entrada. Esto significa que puedes ser advertido de grabar la base de datos antes de salir, incluso sin haber cambiado nada explicitamente.
  • Cuando la base de datos se abre en modo sólo lectura, las horas de acceso no se actualizan.

La tecla Escape cierra la aplicación

Estando seleccionada, puede usarse Esc para cerrar Password Safe cuando el programa está maximizado. Si está activado el icono en la bandeja de sistema (a través de la opción Mostrar icono en el área de notificación), entonces Esc sólo cierra la ventana principal, que puede reabrirse haciendo doble clic en el icono del área de notificación.

Tecla rápida

Estando selecionada, presionando las tecla en la secuencia a la derecha restaurará PasswordSafe desde el área de notificación, si está minimizado, o lo traerá al primer plano, si está tras otras aplicaciones. La secuencia puede cambiarse cuando la opción está seleccionada.

Acción al hacer doble clic

Te permite definir qué acción hará PasswordSafe cuando hagas doble clic en una entrada. El valor por defecto es copiar la contraseña de la entrada al portapapeles. Las opciones disponibles son:

  • Autoescritura
  • Abrir URL
  • Ir a URL + Autoescritura
  • Copiar notas al portapapeles
  • Copiar contraseña al portapapeles
  • Copiar contraseña al portapapeles, minimizar
  • Copiar usuario al portapapeles
  • Ejecutar comando
  • Enviar correo
  • Ver/Editar entrada seleccionada

El elemento copiar contraseña y minimizar no funcionará como se espera si está seleccionada la opción "Borrar portapapeles al minimizar" en la pestaña de opciones de Seguridad.

Autoescritura

  • Minimizar tras autoescritura Por defecto, Password Safe se minimiza al realizar autoescritura. Si la opción no está marcada, Password Safe se situará tras todas las ventanas mostradas en su lugar.
  • Formato autoescritura por defecto Aquí puedes indicar la cadena a usar por defecto para todas las entradas. Puedes modificar este comportamiento en cada entrada. Esta opción es útil, por ejemplo, si quieres cambiar los retardos para todas las entradas. Consulta aquí para más detalles sobre autoescritura.

Usuario por defecto

Esto te permite fijar un usuario por defecto que se utilizará automáticamente cada vez que se genere una nueva entrada. Estando seleccionado, el nombre introducido se insertará por defecto en el campo usuario de las nuevas entradas. Por supuesto, puedes editarlos si es necesario.

Navegador alternativo

El navegador que indiques en este campo se usará al seleccionar la opción "Abrir URL" de una entrada, cuando la URL de la entrada tenga "[alt]" antes de la dirección, por ejemplo, "[alt]http://www.foo.net". Esto es útil, por ejemplo, si tu navegador por defecto es Firefox y quieres acceder a un sitio triste y lamentable que funciona mejor con Internet Explorer, en cuyo caso debes indicar Internet Explorer como tu Navegador alternativo (normalmente "C:\Archivos de programa\Internet Explorer\iexplorer.exe).
Puedes indicar parámetros al navegador a tras del campo Parámetros de línea de comandos.


Administrar el historial de contraseñas

historial de contraseñas

Cuando cambias la contraseña de una entrada,Password Safe puede guardar las contraseñas previas asociadas con la entrada. Esto puede ser útil por ejemplo, si el cambio no se lleva a efecto en el sitio asociado con este entrada. Esta opción indica si las contraseñas recientes se almacenan por defecto en las nuevas entradas. Siempre puedes modificar esto para una entrada dada en el diálogo Añadir entrada o Editar/Ver entrada.

Guargar N contraseñas anteriores por entrada

Seleccionar esta casilla y fijar el valor correspondeinte define la retención de contraseñas por defecto para las nuevas entradas.

Organizar historial de contraseñas de las entradas actuales

Esta sección te permite modificar el historial de contraseñas de las entradas existentes como sigue:
  • Sin cambios - como dice.
  • Dejar de guardar contraseñas previas - Este es el equivalente de desmarcar la casilla "Guardar N contraseñas anteriores" en todas las entradas de la base de datos. No se perderá ningún historial, sólo dejarán de guardarse los siguentes cambios hasta que se reactive guardar el historial.
  • Empezar a guardar contraseñas previas - Es el equivalente de fijar la opción "Guardar Ncontraseñas anteriores" en todas las entradas de la base de datos. Las entradas sin historial guardarán hasta el número anterior de contraseñas. Las entradas con historial de contraseñas seguirán los cambios, pero el número de entradas guardadas no cambiará.
  • Establecer número máximo de contraseñas guardadas al valor de arriba - Todas las entradas, permiten guardar hasta el número anterior de contraseñas. Sin embargo, no se perderá historial si una entrada siten más de este número de entradas almacenadas.


Pestaña seguridad

La pestaña seguridad da acceso a opciones de seguridad controladas por el usuario. La facilidad de uso y seguridad del programa están afectadas por las opciones listadas aquí, mero no la base de datos encriptada subyacente.

Borrar portapapeles al minimizar

Estando seleccionado, el programa borra el contenido del portapapeles de cualquier dato almacenado (como una contraseñas) al minimizar la aplicación. Esto evita que otra persona o programa lea el contenido del portapapeles. Seleccionando esta opción con la acción de doble click "Copiar contraseña al portapapeles, minimizar" de la pestaña de opciones Misc ocasionará resultados inesperados (la contraseña se copiará, pero inmediatamente se borrará del portapapeles).

Borrar portapapeles al salir

Estando seleccionado, el programa borra el contenido del portapapeles de cualquiere dato almacenadao (como una contraseña) cuando el programa se minimiza o cierra. Esto evita que otra persona o programa lea el contedido del portapapeles.

Confirmar copia de elemento al portapapeles

Estando seleccionado, se pide confirmación cada vez que una contraseña se copia de la base de datos al portapapeles.

Bloquear base de datos al minimizar

Estando seleccionado, bloquea la base de datos de contraseña cuando el programa se minimiza. Cuando se vuelve a maximizar, se requiere la contraseñas para acceder al programa.

Bloquear base de datos al bloquear equipo

Selección esta opción hace que la base de datos de contraseñas se bloquee cuando se bloquea la sesión, previniendo así accesos no autorizados por usuario que pudieran tener acceso al equipo.

Bloquear base de datos después de...

Seleccionar esta opción y fijar un intervalo de tiempo hace que Password Safe bloquee la base de datos de contraseñas si transcurre el intervalo de tiempo fijado sin ninguna acción del usuario en la aplicación.


Pestaña sistema

La pestaña sistemas da acceso a opciones relacionadas con la interacción de Password Safe con el sistema en que se ejecuta.

Mostrar icono en el área de notificación

Si está seleccionado, Password Safe se minimizará al aréa de notificación del sistema. Si no está seleccionado, el programa se minimizará a la barra de tareas.

El icono en el área de notificación indica si la base de datos está bloqueada ( bloqueada) o desbloqueada ( desbloqueada). Si está bloqueada, se solicitará la contraseña maestre al volverla a primer plano.

Recordar últimas N entradas usadas en el menú del área de notificación

Si la opción Mostrar icono en el área de notificación está activada, puedes hacer clic derecho en el icono del área de notificación para obtener las entradas usadas más recientemente sin ir a la pantalla de la aplicación. Esta opción te permite configurar cuantas entradas recientes quieres mantener en las lista del icono del área de notificación.

Ocultar icono (la tecla de acceso DEBE estar activada)

Si está seleccionada, hará que Password Safe ocurte su icono en el área de notificación. Esta funcionalidad sólo está disponible si la tecla rápida para iniciar o reabrir Password Safe está activada.

Iniciar PasswordSafe al iniciar sesión

Si está seleccionada, hará que se inicie Password Safe automáticamente en el área de notificación al iniciar sesión. Se te pedirá la contraseñas maestra la primera vez que hagas doble clic en el icono del área de notificación, no antes.

Bases de datos Passwordafe recientes

Este control te permite configurar cuantas bases de datos abiertas recientemente se muestran en el menú Archivo. Debes salir y reiniciar Password Safe para que tengan efecto los cambios en este control.

Bases de datos recientes en el menú archivo en vez de en un submenú

Esta opción determina como se presentan las bases de datos abiertas recientemente en el menú archivo - directamente en el menú o como un submenú.

Abrir base de datos en sólo lectura por defecto

Fijar esta opción hará que Password Safe abrás las bases de datos en modo sólo lectura por defecto. Esto puede ser util en un entorno multiusuario, como por defecto Password Safe permite acceso de escritura a la primera persona que abre la base de datos, restringe a las demás a modo sólo lectura. Con esta opción, puedes determinar por la política del sitio quién tendra acceso de escritura a una base de datos dada.

Permitir multiples instancias (todas las instancias deben reiniciarse)

Eliminar configuración de PasswordSafe del registro

Con anterioridad a la versión 3.05, Password Safe utilizaba el registro para almacenar datos de configuración, tales como configuración de opciones, última base de datos abierta, etc. A partir de esa versión, esa información de configuración está partida entre la específica de la base de datos y la específica del usuario/máquina, esta última está almacenada en un archivo de configuración. Seleccionar esta opción y pulsar el botón Aplicar hace que se borren las opciones en el registro. Esto es útil si quieres eliminar todo rastro de Password Safe de tu PC. De cualquier forma, las antiguas versiones de Password Safe volverán a sus valores por defecto para algunas opciones de configuración.
Notas:
  • Si nunca se ha instalado una versión previa de Password Safe, o si los datos ya han sido eliminados, la casilla de configuración y el botón Aplicar no se mostrarán.
  • En algunas extrañas circunstancias, en que Password Safe no puede crear o escribir en el fichero de configuración, se utilizará el registro.

Migrar configuración de PasswordSafe al directorio del usuario

Con anterioridad a la versión 3.22, PasswordSafe mantenía las preferencias de la aplicación (como algunas opciones de usuario, últimos archivos abiertos, tamaño y posición de la ventana, etc.) en un archivo en el mismo directorio del ejecutable de PasswordSafe. Esto ha causado problemas con versiones recientes de Windows en que los usuarios no tienen acceso de escritura en este directorio. Por tanto, a partir de la versión 3.22, el archivo de configuración (pwsafe.cfg) se creará en la ubicación estandar para tales ficheros (en el directorio de usuario 'Configuración local\Datos de programa').
Por defecto, las actualizaciones de instalaciones no cambian el archivo de preferencias existente ("si no está roto, no lo arregles"). De cualquiere modo, si un usuario quiere cambiar a la nueva configuración manualmente, seleccionando esta opción y pulsando en 'Aplicar' se llevará a efecto.

Mas detalladamente: El archivo de configuración está diseñado para soportar múltiples usuarios en múltiples máquinas. La función de migración cambiará la configuración del usuario actual (asociado con el actual PC) del archivo de configuración a una nueva ubicación. Si hay otras configuraciones propias de otro usuario/máquina en el archivo no se tocarán. Si no hay otras configuraciones tras la migración, se eliminará el archivo.
Si quieres compartir un archivo de configuración común entre usuarios y/o entre distintos PCs, puedes mantener el archivo en directorio del ejecutable, o especificar su localización explicitamente utilizando la opción '-g archivo-configuración', tal como se describe en argumentos de la línea de comandos.


Pestaña atajos

La pestaña atajos te permite modificar los atajos de teclado por defecto (también conocidos como aceleradores) para las distintas acciones definidas en Password Safe. Para cambiar un atajo (o añadir uno nuevo), selecciona la fila cona la acción que quieres cambiar, entonces pulsa en el campo 'Tecla atajo' de esa entrada. Cualquier combinación de teclas que selecciones se definirá como atajo de esa acción. Por ejemplo, defined as the shortcut for this action. For example, para el el cuadro de diálogo de propiedades de archivo aparezca cuando se pulsen Control, Alt and 'p', selecciona la fila Archivo >> Propiedades, pulsa en el campo 'Tecla atajo', y después pulsa las teclas Control Alt y p. El texto 'Ctrl+Alt+P' aparecerá en el campo tecla atajo, y cuando pulses Aceptar el cambio tendrá efecto. Para más detalles sobre las teclas que pueden (y no) definirse como atajos, ver esto.

Puedes definir atajos donde no los hay, al igual que reemplazar los atajos por defecto con aquellos de tu elección. Los atajos se almacenan en tu archivo de preferencias, y estarán disponibles la siguiente vez que inicie Password Safe.

Si quieres eliminar un atajo y volver al atajo por defecto de una acción determinada, selecciona el campo 'Tecla atajo' y haz clic derecho. Aparecerá un menú contextual que te permitirá hacerlo. Para revertir todos los atajos a sus valores por defecto, pulsa en 'Reiniciar todo'.


Alias de contraseñas

Si estás usando un sistema que te permite compartir la misma contraseña en distintas maquinas/servidores/aplicaciones, etc. puedes configurar las entradas de Password Safe en consecuencia, de manera que cambiar una contraseña afecte a todas las otras entradas relacionadas. Esto se conoce como alias de entradas. Esta sección describe como definir y usar esos alias.

Resumen

La idea básica es permitir que la contraseña de una entrada pueda ser referenciada por otra. La entrada referenciada se llama base, y la entrada (o entradas) que la referencia se llama alias. Cuando se fija una entrada como alias de otra entrada, la contraseña del alias se sincroniza con el contraseñas de esa entrada: Si copias la contraseña del alias al portapapeles, la contraseña que se copia es la de la base. Si cambias la contraseña de la base, se refleja inmediatamente en todos los alias asociados con la base. Aunque esto pueda sonar complicado, de hecho es muy simple e intuitivo de usar. La parte más complicada es fijar los aslias, como se describe abajo.

Definiendo un alias

En Password Safe, una entrada puede hacer referencia a la contraseña de otra por medio de una contraseña con un formato especial en la entrada referente. El formato es el "nombre" de la entrada referenciada entra corchetes. Generalmente "nombre" es sinónimo el campo título de una entrada, de forma que si el título de la entrada base es "maestro", por ejemplo, introduciendo "[maestro]" (sin las comillas) en el campo contraseña de otra entrada es suficiente para definir la otra entrada como un alias de "maestro".

De forma más general, un "nombre" puede contener todos los campos siguientes, separados por dos puntos: Grupo, Titulo y Usuario. Si el título es único en la base de datos, entonces los otros campos son opcionales. Del mismo modo, si el grupo y título juntos o título y usuario juntos identifican una única entrada, el correspondiente usuario o grupo no tiene porqué indicarse.

En las entradas de Password Safe, sólo el campo título es obligatorio. Los campos grupo y usuario son opcionales siempre que la combinación resultante "grupo/título/usuario nombre" sea única. Como se indica más arriba, la "contraseña" del alias tiene el formato [g:t:u] pero de hecho sólo tienes que especificar información suficiente para identificar de forma única la entrada base. Si hay sólo una entrada en la base de datos con título 't', entonces [t] será suficiente - puesto que título es obligatorio y se indica un elemento, se asume que es el título. Si hubiera más de una entrada con ese título, serías advertido de esa circunstancia, y necesitarias ser más específico para identificar la entrada base añadiendo su grupo o su usuario o ambos. Cuando hay sólo una entrada que coincide con la información proporcionada, se aceptar cualquiera de los siguientes formatos: [g:t:u], [g:t], [t:u] or [t]. Especificar dos puntos sin un valor implica un campo vacío, por ejemplo [g:t:] indica la entrada con título 't' en grupo 'g' y sin nombre de usuario y [:t:] indica la entrada con título 't' en la raíz sin nombre de usuario etc.

Los siguientes ejemplo deberían clarificar esto.

Examples

1. Si el título de la entrada base es "Servidor LDAP", y no hay otras entradas con ese título, entonces un alias se definirá con una entrada que tenga "[Servidor LDAP]" como contraseñas.

2. Si hay entradas "Servidor LDAP" en dos grupos diferentes, digamos "Dept. A" y "Dept. B", se puede especificar un alias a este último con "[Dept. B:Servidor LDAP]". No tienes que indicar el usuario si la información indicada identifica sólo una entrada base.

3. Los nombre de usuario pueden utilizarse para diferenciar entre entradas similares, por ejemplo "[Servidor LDAP:José]" y "[Servidor LDAP:María]".

4. Finalmente, los tres campos pueden indicarse , como en "[Dept. A:Servidor LDAP:José]"

Visualización

Las entradas base, esto es, las entradas referenciadas por al menos un alias, se muestran con un triángulo verde en lugar de un cuadrado verde en la vista de árbol jerarquizado.

Las entradas alias se muestran con triángulos blancos.

ejemplo de alias


Formato de importación y exportación texto sin formato

Notas sobre importar y exportar texto sin formato

Atención: La exportación de información sensible de una base de datos de Password Safe a un archivo de texto tiene consecuencias graves de seguridad. Esta operación va a crear una copia sin protección de las contraseñas de la base de datos. La supresión de esta copia después de su uso no es suficiente, se deben tomar otras acciones para eliminar adecuadamente los datos (por ejemplo utilidades de “triturado”). La exportación de datos sensibles pasa por alto la seguridad que proporciona Password Safe.

Nota: La exportación e importación a archivos de texto se cambió en la versión V3.06. Esta página describe el formato actual.

El texto exportado

  • Comienza con una fila de títulos como primer registro del archivo de texto
  • Usa un delimitador para reemplazar el caracter “nuevalinea” en un campo notas con varias líneas y el punto (‘.’) si aparece en el campo título. El valor por defecto es ‘»’ [Alt+0187], que se puede reemplazar si es necesario.

Se asume que el texto importado tiene:

  • Una fila de títulos como primer registro del archivo de texto.
  • Un delimitador para restituir el caracter “nuevalinea” en un campo notas con varias líneas y el punto (‘.’) si aparece en el campo título. El valor por defecto es ‘»’ [Alt+0187], que se puede reemplazar si es necesario.

La fila de títulos al exportar todos los datos contiene los siguientes campos por defecto, separados por tabuladores.

  • Grupo/Título
  • Usuario
  • Contraseña
  • URL
  • Autoescritura
  • Fecha de creación
  • Modificación de la contraseña
  • Último acceso
  • Caducidad de contraseña
  • Intervalo de caducidad de contraseña
  • Hora de modificación del registro
  • Política de contraseñas
  • Historial
  • Ejecutar comando
  • ADC
  • Correo
  • Notas

Cuando exporte datos, puede utilizar la opción “avanzada” para excluir cualquier número de estos campos de la fila de título y registros. La opción avanzada también le permite especificar un subconjunto de las entradas a la exportación, como se muestra a continuación.

Opciones avanzadas de exportación de texto

Durante la importación, la fila de títulos proporcionada debe incluir “encabezados de columna” que casen exactamente con uno de los anteriores. Si se repite algún “encabezado de columna”, sólo la información del último se añadirá a las entradas durante la importación. Si un “encabezado de columna” no casa con los anteriores, el dato de esa columna se ignorará al importar. Los campos deben estar separados con el separador de campos indicado en el diálogo de importación de texto.

Notas:
  • Para importar datos en Password Safe, el título y contraseña deben estar presentes y ninguno puede estar vacio, tal como al añadir una nueva entrada a la base de datos.
  • No hay restricción de orden de los “encabezados de columnas”. Password Safe utilizará la fila títulos proporcionada para añadir datos al campo apropiado.

Formato de los datos

Encabezado de columna/Campo | Comentarios
Encabezado de columna/Campo | Si aparecen, los grupos se separan con puntos (‘.’). El campo título no puede estar vacío o contener el caracter delimitador.
Usuario
Contraseñas | No puede estar vacía.
URL
Autoescritura
Fecha de creación | Ver nota 1 más abajo
Hora de modificación de contraseña | Ver nota 1 más abajo
Último acceso | Ver nota 1 más abajo
Caducidad de contraseña | Ver nota 1 más abajo
Intervalo de caducidad de contraseña | Ver nota 1 más abajo
Hora de modificación del registro | Ver nota 1 más abajo
Política de contraseñas | Ver nota 3 más abajo
Historial | Ver nota 2 más abajo
Ejecutar comando
ADC | = ‘Acción con Doble Clic’. Ver nota 4 más abajo
Correo
Notas
  • El campo notas debe estar delimitado por comillas dobles ("como esto").
  • Le campo notas no debe contener el campo delimitador puesto que al importarlo se transformará en una nueva línea.

Notas: 1

Los campos de hora puede tener uno de los siguientes 5 formatos:

1. | aaaa/mm/dd hh:mm:ss | ejemplo, 2007/01/26 19:31:25
2. | ddd MMM dd hh:mm:ss aaaa | ejemplo, Fri Jan 26 19:31:25 2007
3. | aaaa-mm-ddThh:mm:ss | ejemplo, 2007-01-26T19:31:25
4. | 0 | Deja el campo sin fijar
5. | now | Usa la hora de la operación de importación

donde:

aaaa | El año completo. El valor esta entre 1970 y 2038.
mm | El mes; ejemplo 01 = Enero, 02 = Febrero, etc.
dd | El día del mes
MMM | La abreviatura del mes en inglés; ejemplo Jan = Enero, Feb = Febrero, etc.
ddd | La abreviatura del día de la semana en inglés; ejemplo Mon = Lunes, Tue = Martes, etc.
hh | La hora usando 24 horas.
mm | Los minutos
ss | Los segundos

Nota: El formato ‘2’ es la salida de la función ANSI C ‘asctime’ y el formato ‘3’ sigue el estandar ISO 8601.

Notas: 2

El historial de contraseñas se representa en el registro de la entrada exportada como un campo de texto compuesto por un encabezado seguido por el número de entradas precisas de viejas contraseñas:

Encabezado de historial de contraseñas:

  • 1 dígito hexadecimal de estado para almacenar PWH para esta entrada (0 = no; 1 = si)
  • 2 dígitos hexadecimales con el máximo número de entradas
  • 2 dígitos hexadecimales con el número de entradas guardadas

Cada entrada de historial de contraseñas:

  • 8 dígitos hexadecimales con la hora en que se fijó la contraseña
  • 4 dígitos hexadecimales con la longitud de la contraseña
  • cadena de caracteres con la antigua contraseña

Notas: 3

La política de contraseñas se representa en el registro de la entrada exportada como un campo de texto 'ffffnnnllluuudddsss' en formato hexadecimal, ejemplo 'F000010004002005003'. 6 valores hexadecimales están contenidos en este formato. El primero tiene 4 dígitos, los otros 3.

'ffffnnnllluuudddsss' significa en detalle:

  • ffff : 4 dígitos hexadecimales representando los siguientes indicadores
    • 0x8000: utilizar caracteres en minúsculas
    • 0x4000: utilizar caracteres en mayúsculas
    • 0x2000: utilizar números
    • 0x1000: utilizar símbolos
    • 0x0800: utilizar sólo caracteres hexadecimales (0-9,a-f) (si está fijado, no pueden estarlo los otros indicadores)
    • 0x0400: utilizar caracteres de fácil lectura
    • 0x0200: utilizar contraseñas pronunciables
    • 0x01FF: no utilizado
  • nnn : 3 dígitos hexadecimales : longitud de la contraseña
  • lll : 3 dígitos hexadecimales : mínimo número de caracteres en minúsculas
  • uuu : 3 dígitos hexadecimales : mínimo número de caracteres en mayúsculas
  • ddd : 3 dígitos hexadecimales : mínimo número de dígitos
  • sss : 3 dígitos hexadecimales : mínimo número de símbolos

La política de contraseñas 'F000010004002005003' significa

  • F000 : usar minúsculas, mayúsculas, números y símbolos
  • 010 : usar al menos 16 (dec) caracteres
  • 004 : usar al menos 4 caracteres en minúsculas
  • 002 : usar al menos 2 caracteres en mayúsculas
  • 005 : usar al menos 5 dígitos
  • 003 : usar al menos 3 símbolos

Notas: 4

Los siguientes valores están disponibles para la Acción tras Doble Clic:

  • -1: Por defecto
  • 0: Copiar contraseña al portapapeles
  • 1: Ver/editar entrada
  • 2: Autoescritura
  • 3: Ir a URL
  • 4: Copiar notas al portapapeles
  • 5: Copiar usuario al portapapeles
  • 6: Copiar contraseñas al portapapeles y minimizar
  • 7: Ir a URL + Autoescritura
  • 8: Ejecutar comando
  • 9: Enviar correo


Preferencias

Preferencias de PasswordSafe

Al igual que muchas aplicaciones, PasswordSafe le permite configurar su comportamiento y apariencia que mejor se ajuste a su gusto y necesidades. Muchas aplicaciones almacenan las preferencias de este tipo en el 'Registro' de Windows, como una cuestión de convención y conveniencia. Las versiones anteriores de PasswordSafe también utilizaban el registro, pero esto ha demostrado ser problemático por las siguientes razones:
1. Algunas de las preferencias configurables están relacionadas con la seguridad, y almacenarlos en un repositorio abierto, como el registro de Windows, puede permitir a un atacante obtener acceso a la base de datos (por ejemplo, si el atacante desactivar el bloqueo de la base de datos después de un tiempo de espera de inactividad, el usuario asumirá que la base de datos se ha bloqueado de forma segura mientras sale a almorzar, mientras el atacante podría acceder a su conveniencia).
2. Muchas personas usan PasswordSafe en un disco-llave o de otra manera compartiendo la misma base de datos entre varias máquinas. Es muy difícil compartir los datos de configuración en un registro de tal manera.

PasswordSafe tiene una serie de preferencias, cada una con un valor por defecto razonable. Cuando un usuario cambia la configuración a un valor no predeterminado, el nuevo valor es almacenado por PasswordSafe.
PasswordSafe define las preferencias como relacionadas o no con la seguridad. Las primeras se mantienen en la base de datos, cifrado con la misma clave que los datos del usuario.
Las preferencias no relacionados con la seguridad se guardan en un archivo de configuración, pwsafe.cfg. Este archivo está en formato XML, con secciones por máquina y por usuario, para que el archivo se puede compartir entre diferentes usuarios, así como entre diferentes máquinas.
Por defecto, pwsafe.cfg se guarda en el mismo directorio que el programa ejecutable pwsafe.exe. Sin embargo, si se establece la variable de entorno PWS_PREFSDIR, pwsafe usará el fichero de configuración almacenados allí. Esto es útil si los permisos de escritura en el directorio de instalación de pwsafe.exe están restringidos.

En las siguientes tablas se describen los elementos de configuración. Mucho de ellos son configurables a través del diálogo Herramientas->Opciones.

Preferencias lógicas (cierto/falso)

Preferencia | Predeterminado | Almacenado en | Comentario
alwaysontop | falso | pwsafe.cfg | Ventana principal siempre en primer plano
showpwdefault | falso | base de datos |
showpwinlist | falso | base de datos |
sortascending | cierto | base de datos |
usedefuser | falso | base de datos |
saveimmediately | cierto | base de datos |
pwuselowercase | cierto | base de datos | Política de generación de contraseñas
pwuseuppercase | cierto | base de datos | Política de generación de contraseñas
pwusedigits | cierto | base de datos | Política de generación de contraseñas
pwusesymbols | falso | base de datos | Política de generación de contraseñas
pwusehexdigits | falso | base de datos | Política de generación de contraseñas
pweasyvision | falso | base de datos | Política de generación de contraseñas
dontaskquestion | falso | pwsafe.cfg |
deletequestion | falso | pwsafe.cfg |
DCShowsPassword | falso | pwsafe.cfg |
DontAskMinimizeClearYesNo | cierto | pwsafe.cfg |
DatabaseClear | falso | pwsafe.cfg |
DontAskSaveMinimize | falso | pwsafe.cfg |
QuerySetDef | cierto | pwsafe.cfg |
UseNewToolbar | cierto | pwsafe.cfg |
UseSystemTray | cierto | pwsafe.cfg |
LockOnWindowLock | cierto | pwsafe.cfg |
LockOnIdleTimeout | cierto | base de datos | Bloquear tras IdleTimeout minutos
EscExits | cierto | pwsafe.cfg |
HotKeyEnabled | falso | pwsafe.cfg |
MRUOnFileMenu | cierto | pwsafe.cfg | Bases de datos recientes
MaintainDateTimeStamps | falso | base de datos |
SavePasswordHistory | falso | base de datos |
FindWraps | falso | pwsafe.cfg |
ShowNotesDefault | falso | base de datos |
BackupBeforeEverySave | cierto | pwsafe.cfg |
PreExpiryWarn | falso | pwsafe.cfg |
ExplorerTypeTree | falso | pwsafe.cfg | Mostrar grupos primero en vista árbol
ListViewGridLines | falso | pwsafe.cfg | Mostrar líneas de cuadrícula en lista
MinimizeOnAutotype | cierto | pwsafe.cfg |

Preferencias numéricas

Preferencia | Predeterminado | Almacenado en | Min | Max | Comentario
column1width | n/a | pwsafe.cfg | n/a | n/a |
column2width | n/a | pwsafe.cfg | n/a | n/a |
column3width | n/a | pwsafe.cfg | n/a | n/a |
column4width | n/a | pwsafe.cfg | n/a | n/a |
sortedcolumn | 0 | pwsafe.cfg | 0 | 15 |
pwlendefault | 8 | base de datos | 4 | 1024 | Longitud de la contraseña
maxmruitems | 4 | pwsafe.cfg | 0 | 20 | Bases de datos recientes
IdleTimeout | 5 | base de datos | 1 | 120 | Minutos
DoubleClickAction | DoubleClickCopyPassword | pwsafe.cfg | n/a | n/a |
HotKey | none | pwsafe.cfg | n/a | n/a |
MaxREItems | 25 | pwsafe.cfg | 0 | 25 | Entradas recientes
TreeDisplayStatusAtOpen | AllCollapsed | base de datos | n/a | n/a |
NumPWHistoryDefault | 3 | base de datos | 0 | 255 | contraseñas en historial
BackupSuffix | 0 | pwsafe.cfg | n/a | n/a |
BackupMaxIncremented | 1 | pwsafe.cfg | 1 | 999 |
PreExpiryWarnDays | 1 | pwsafe.cfg | 1 | 30 | Aviso caducidad contraseñas

Preferencias de texto

Preferencia | Prederminado | Almacenado en | Comentario
currentbackup | <none> | pwsafe.cfg | Nombre y trayectoria del último archivo de copia de seguridad
currentfile | <none> | pwsafe.cfg | Archivo abierto actualmente (último)
lastview | tree | pwsafe.cfg | Última vista seleccionada: Árbol o lista
defusername | <none> | base de datos |
treefont | <none> | pwsafe.cfg |
BackupPrefixValue | <none> | pwsafe.cfg |
BackupDir | <none> | pwsafe.cfg |
AltBrowser | <none> | pwsafe.cfg | Navegador alternativo
ListColumns | <none> | pwsafe.cfg | Orden de columnas
ColumnWidths | <none> | pwsafe.cfg | Tamaño de columnas
DefaultAutotypeString | \u\t\p\t\n | base de datos |


Ejecutar comando

Un campo "Ejecutar comando" de una entrada puede contener un comando que se ejecutará cuando se selecciona la acción ejecutar comando. El comando puede ser cualquier cosa que pueda ejecutarse en el diálogo Inicio->Ejecutar... de tu computador.

Además, Password Safe puede pasar argumentos al comando como el nombre de la entrada contraseña, etc., como se describe más abajo. Esto te permite programar acciones complejas, como ejecutar un programa de acceso remoto (PuTTY, por ejemplo) y pasarle el usuario y contrasaña asociado con la entrada.

En general, las 'variables' son reemplazadas por los valores asociados con ellas, antes de transferirlos al ordenador para su ejecución. El signo ('$') dólar se emplea para indicar una variable.

  • Las variables se especifican como '$nombre', y se distingue entre mayúsculas y minúsculas. Los nombres de variables siempre comienzan con un carácter alfabético y el resto de los caracteres son alfanuméricos. El nombre de la variable se termina al encontrarse con un carácter no alfanumérico (como un espacio) o al alcanzar el final del campo Ejecutar comando.
    • Para utilizar una variable seguida de inmediato por un carácter alfanumérico, escribe el nombre de la variable entre llaves, por ejemplo, '${nombrevar}cadena'.
    • Para utilizar un '$' en la cadena como texto normal (sin indicar que el texto que sigue es un nombre de variable), utiliza una barra invertida ('\'), por ejemplo '\$texto' se convierte en '$texto' y no es tratada como una variable llamada 'texto'.
    • Para utilizar una barra invertida antes de que un '$', precédela con una barra invertida, por ejemplo, '\\$nombre' se convierte en "\$nombre' en el texto resultante y' $nombre' se trata como una variable. No hay que preceder una barra invertida con otra barra invertida a menos que preceda a un '$' indicando una variable.
    • Una variable puede ser seguido por un valor numérico entre corchetes que se denomina un 'valor índice'. El valor índice 'n' puede estar precedido por '+' o '-' ejemplo [-2] o [2] o [+2]. Password Safe interpreta un índice con valor cero como todo el campo.

  • Actualmente se reconocen las siguientes variables:

    • Relacionados con la aplicación:
      • appdir El directorio que contiene la apliación Password Safe. Ver notas 1 y 2 más abajo.

    • Relacionados con la base de datos actual:
      • dbdir | Directorio de la base de datos actualmente abierta. Ver notas 1 y 2 más abajo.
fulldb | Ruta de acceso completa, nombre de archivo y extensión de la base de datos abierta. Ver nota 2 más abajo.
dbname | Nombre de archivo de la base de datos abierta.
dbextn | Extensión de la base de datos abierta.

    • Relacionadas con la entrada actual:
      • g o group | Grupo (estructura de árbol completo hasta la raíz con grupos separados por puntos).
G o GROUP | El grupo que contiene esta entrada sólo.
t o title | Título
u o user | Usuario
p o password | Contraseña
a o autotype | Autoescritura. Ver nota 5 más abajo.
url | URL
n o n[0] | El campo notas completo (también: notes or notes[0]). Ver nota 3 más abajo.
n[i] o notes[i] | Línea i del campo Notas empezando por el principio, i=1 es la primera línea, i=2 es la segunda línea etc. Ver nota 4 más abajo.
n[-i] o notes[-i] | Línea idel campo Notas empezando por el final, i=1 es la última línea, i=2 es la penúltima línea etc. Ver nota 4 más abajo.

      Notas
      1 | Los nombres de directorio (appdir o dbdir) no tienen una '\' al final. Recuerda añadirla si la necesitas en tu Ejecutar comando.
      2 | El contenido de las variables (incluyendo los valores de directorio y ruta de acceso completa) puede incluir espaciones en blanco. Puedes necesitar encerrar el resultado entre comillas para una correcta ejecución de Ejecutar comando.
      3 | Si el campo Notas contiene más de una línea, se incluirá cualquier retorno de carro (CR) o avance de línea (LF) incrustado. Esto puede causar problemas cuando se ejecuta y CR y/o LF se toman como 'Intro'.
      4 | Cualquier CR y/o LF final se quitan de las líneas individuales seleccionadas del campo Notas.
      5 Si la variable Autoescritura está presente en el comando Ejecutar, se llevará a cabo una vez que la ventana de destino esté activa. La variable y su valor, si existe, será eliminado de la cadena que se ejecuta. Esta variable puede aparecer en cualquier lugar en el comando Ejecutar, ya que sólo especifica lo que Password Safe hará después de la cadena de comando se ha ejecutado. A diferencia de otras variables, ésta podrá tomar un valor para reemplazar el valor actual de la entrada. El formato es el siguiente (puede indicarse '$autotype' en lugar de '$a' en los ejemplos siguientes):
      $a | Usa el valor de la entrada actual.
${a} | Usa el valor de la entrada actual (se usa si hay texto que sigue a la variable '$a').
$a(valor) | Usa la cadena especificada entre paréntesis para la autoescritura.
${a}(valor) | Usa la cadena especificada entre paréntesis para la autoescritura.

      Nota: Asegúrate de añadir comillas alrededor de la cadena si es necesario, por ejemplo si el directorio de la base de datos contiene espacios, para acceder a un archivo de texto en el que basa en el nombre de base de datos abierta necesitarás lo siguiente (con comillas):
      '$dbdir\\$dbname.txt'
      La barra invertida está precedida por otra de forma que '$dbname' se reconoce como una variable.

      En Windows se lleva a cabo la sustitución normal de las variables de entorno (especificado en %nombre_variable%). Por ejemplo: '%windir%\notepad.exe' puede convertirse (dependiendo de tu instalación) en 'C:\Windows\notepad.exe'. Los valores de entorno se puede comprobar ejecutando 'cmd.exe' e indicando el comando 'set' sin parámetros. Cualquier variable de entorno desconocida se deja sin cambios en Ejecutar comando, por ejemplo, %xyz%\notepad.exe permanece como %xyz%\notepad.exe si la variable 'xyz' no está definida. Nota: Las variables de entorno de Windows no distinguen maýusculas y minúsculas.


Atajos de teclado

Atajos de teclado / Aceleradores

Los siguientes son los detalles y las limitaciones con respecto a la posibilidad de definir atajos de teclado personalizados para PasswordSafe.

Estas combinaciones de teclas han sido probadas en un teclado extendido de 102 teclas Reino Unido. Los caracteres estándar debería funcionar en cualquier otro teclado con caracteres latinos. Algunas combinaciones de teclas pueden ser diferentes en estos teclados - por ejemplo en un teclado de Reino Unido el símbolo # tiene su propia tecla (con la tilde ~), pero en un teclado de EE.UU. está por encima de la tecla 3 (es decir, Mays+3). Por favor, lea esta tabla y trasladela a su teclado específico según corresponda - siempre se puede experimentar para ver si una combinación de teclas particular funciona en tu caso.

Dependiendo de su traducción, ciertas teclas con la tecla Alt están reservadas. Corresponden a las letras utilizadas para invocar el menú principal. Al presionar la tecla Alt en la pantalla principal se mostrarán estos caracteres, como se destaca. En español, esto es Alt+A (Archivo), Alt+E (Editar), Alt+V (Ver), Alt+H (Herramientas) y Alt+U (Ayuda). Para otras traducciones, fíjate en las letras subrayadas en el menú principal para determinar cuales están reservadas. Por ejemplo, en la traducción al alemán el menú "Archivo" se transforma en "Datei" y por tanto Alt+D está reservada en lugar de Alt+A etc.

La tecla Intro también está reservada ya que se usa para fijar el valor de un atajo en la página de propiedades Herramientas->Opciones->Atajos. Por tanto, no es posible asignar esta tecla a una función. Ten en cuenta que la función "Expandir/Contraer grupo" en el modo vista de árbol se consigue seleccionando el grupo y presionando la tecla Intro. Aunque esto podría haber sido cambiado y ser válido en cualquier acceso directo, el uso de la tecla Enter para esta función seguiría estando activa, ya que es una función de la vista de árbol. Por esta razón, esta función no se puede cambiar a través de la página de propiedades de accesos directos.

La tecla Escape está reservada para usarse para cerrar la barra de herramientas de búsqueda o para minimizar Password Safe al área de notificación. Es el equivalente del botón Cancelar en cualquier diálogo.

El valor de acceso directo para visualización de una entrada en modo de sólo lectura es la misma que para la edición del texto en modo lectura / escritura. No puede fijarse independientemente. Del mismo moto, 'Borrar entrada' es el mismo que 'Borrar grupo' y 'Renombrar entrada' es el mismo que 'Renombrar grupo'. Se muestran en la página de propiedades de atajos como 'Eliminar' y 'Renombrar' respectivamente.

Algunas teclas están reservadas por Windows - por ejemplo Ctrl+Alt+Supr; Tab; Mayus+Tab; Alt+Tab; Alt+Mayus+Tab etc.

Las teclas no estandar no están soportadas (por ejemplo aquellas que sólo están en un teclado Kanji).

Los atajaos de PasswordSafe no reconocen la diferencia entre las teclas Alt, Ctrl y Mayus de la izquierda del teclado de las que están a la derecha. Esto puede hacer algunas combinaciones de teclas indisponibles en algunos teclados. Por ejemplo, el simbolo del Euro en un teclado extendido Reino Unido 102 es la tecla Alt Dcha (Alt Gr) y la tecla 4. Sin embargo, al pulsar este combinación da como resultado un atajo de teclas Ctrl + Alt +4. Esta es la forma en que funciona el procesamiento de atajos de Microsoft y no es una restricción de Password Safe.

Nota: Configurar teclas no estándar puede hacer que estos accesos directos no estén disponibles si a continuación utiliza otro equipo con un teclado que no tiene estas teclas. Se recomienda que sólo uses las combinaciones que aparecen en esta lista.

En la tabla de abajo, la columna encabezado significa:

Encabezado | Significa pulsar
T | La tecla sola
A+T | La tecla con Alt
C+T | La tecla con Ctrl
M+T | La tecla con Mayus.
A+M+T | La tecla con Alt y Mayus.
C+M+T | La tecla con Ctrl y Mayus.
A+C+T | La tecla con Alt y Ctrl
A+C+M+T | La tecla con Alt, Ctrl y Mayus.

Nombre de tecla | T | A+T | C+T | M+T | A+M+T | C+M+T | A+C+T | A+C+M+T
Retroceso | S | N | S | S | N | S | S | S
Tab | N | N | S | N | N | S | S | S
Intro | R (1) | N | S | N | N | S | S | S
Escape | N | N | N | N | N | N | N | N
Espacio | S | N | S | S | N | S | S | S
Re Pag | S | S | N | S | S | N | N | N
Av Pag | S | S | N | S | S | N | N | N
Fin | S | S | S | S | S | S | S | S
Inicio | S | S | S | S | S | S | S | S
Flecha izquierda | S | S | S | S | S | S | S | S
Flecha arriba | S | S | S | S | S | S | S | S
Flecha derecha | S | S | S | S | S | S | S | S
Flecha abajo | S | S | S | S | S | S | S | S
Imprimir pantalla | N | N | N | N | N | N | N | N
Insertar | S | S | S | S | S | S | S | S
Suprimir | S | N | S | S | N | S | N | S
0-9 | S | S | S | S | S | S | S | S
A-Z | S | S | R (2) | S | S | S | S | S
Tecl num 0-9 | S | S | S | N | S | N | S | N
Tecl num * | S | S | S | S | S | S | S | S
Tecl num + | S | S | S | S | S | S | S | S
Tecl num - | S | S | S | S | S | S | S | S
Tecl num . | S | S | S | N | N | N | N | N
Tecl num / | S | S | S | S | S | S | S | S
F1 | R (3) | S | S | S | S | S | S | S
F2 | S | S | S | S | S | S | S | S
F3 | S | S | S | S | S | S | S | S
F4 | S | R (2) | S | S | S | S | S | S
F5 | S | S | S | S | S | S | S | S
F6 | S | S | S | S | S | S | S | S
F7 | S | S | S | S | S | S | S | S
F8 | S | S | S | S | S | S | S | S
F9 | S | S | S | S | S | S | S | S
F10 | S | S | S | S | S | S | S | S
F11 | S | S | S | S | S | S | S | S
F12 | S | S | S | S | S | S | S | S
Bloq Num | S | S | N | S | N | S | S | S
Bloq despl | S | S | S | S | S | S | S | S
; : (4) | S | S | S | S | S | S | S | S
+ = | S | S | S | S | S | S | S | S
, < | S | S | S | S | S | S | S | S
- _ | S | S | S | S | S | S | S | S
. > | S | S | S | S | S | S | S | S
/ ? (4) | S | S | S | S | S | S | S | S
# ~ (4) | S | S | S | S | S | S | S | S
[ { (4) | S | S | S | S | S | S | S | S
\ | (4) | S | S | S | S | S | S | S | S
] } (4) | S | S | S | S | S | S | S | S
' @ (4) | S | S | S | S | S | S | S | S
` ¬ (4) | S | S | S | S | S | S | S | S

Notas:

  1. Puesto que la tecla Intro se utiliza para establecer el valor del acceso directo, no pueden asignarse a ninguna función.

  2. Ctrl+Q y Alt+F4 están reservados para salir de la aplicación Password.

  3. F1 está reservado pra Ayuda.

  4. Esto depende del teclado.


Creditos

Créditos del programa

Agradecimientos a Bruce Schneier por crear el algoritmo Twofish y por liberar Password Safe al público; y a SourceForge.net por haber acogido el proyecto y el apoyo a la comunidad Open Source.
La versión 3.06 y posteriores de Password Safe utiliza TinyXML para analizar el archivo de configuración de la aplicación. El código de TinyXML se proporciona bajo la licencia zlib.
La versión 3.12 y posteriores de Password Safe utilizan un algoritmo creado por Tom Van Vleck, Morrie Gasser, and Dan Edwards para generar contraseñas pronunciables.

Los vínculos que siguen llevan a varias páginas en el sitio web de SourceForge relacionados con el proyecto Password Safe:

  • Página de inicio de Password Safe: Información y noticias sobre Password Safe así como anunciaos sobre el estado del proyecto y nuevas versiones. La página es mantenida por Brad Chance - ¡Gracias Brad!
  • Equipo de desarrollo: Algunas de las personas que han ayudado a desarrollar y mantener Password Safe.
  • Foro de Password Safe: Un foro de preguntas, y soporte a los problemas.
  • Noticias sobre Password Safe: Feeds RSS disponibles para este proyecto.
  • Página de anuncios y listas de correo de Password Safe con poco tráfico (alrededor de un mensaje cada mes más o menos) y libres de spam.